cancel
Showing results for 
Search instead for 
Did you mean: 

A PopUp is blocked

Occasional Contributor

A PopUp is blocked

When working within a an web app via a bookmark in the IVE.... in this case a sharepoint 2010 site and clicking on a link i'm getting message stating that a PopUp is blocked. This may sound pretty nube and all but I am a nube to these devices and I can't for the life of me figure out how to disable that. Can somebody out there please enlighten me?

15 REPLIES 15
Highlighted
Respected Contributor

Re: A PopUp is blocked

In IE you will need to disable your popup blocker OR add the IVE to your site list that allows pop-ups.

If that does not work, I would recommend opening a case with JTAC for further investigation onto what is happening.

Highlighted
Occasional Contributor

Re: A PopUp is blocked

Hi

If you mean what I think you mean Destroyer, the pop-up is not being blocked by the Web Browser but rather links within Sharepoint 2010 don't work and a message box style window "pops up" - Message title is "Message from webpage" and the the body has a yellow triangle with an exclamation mark in it and the text "PopUp is blocked"

Unfortunately (hope i didn't get your hopes up) I too have this issue and cannot find a solution - the Juniper config does not seem to have Popup blocking in it's configuration.

Can anyone help please?

Highlighted
Occasional Contributor

Re: A PopUp is blocked

Hi Again

Just had a call with Juniper - appears that the links MAY be launching Silverlight which is not supported via a web bookmark (something to do with rewriting). The work around is to use either the WSAM or JSAM - this works but I did have some issues with the ActiveX control on the page (Showed as unknown name and publisher - still work though)

To implement this edit your Web Resource Profile for the Sharepoint site.

Go down to Autopolicy rewriting options (tick this)

Choose "No rewriting (Use JSAM or WSAM your choice depending upon what clients you use)."

Also you will need to edit the role that has access to the sharepoint site

Goto:

User Roles -> ROLENAME -> SAM -> Options

Tick Auto-Launch Secure Application Manager and (IF YOU USE JSAM) Automatic host-mapping and auto close JSAM window on sign out.

Regards Jon

Highlighted
Respected Contributor

Re: A PopUp is blocked

You are correct, the IVE does not have pop up blocking functionality; that is handled by the browser/server application.

Highlighted
Occasional Contributor

Re: A PopUp is blocked

Thanks for all the tips, So far Ive tried the JSAM to make it work properly and its still doing the same thing. No Dice. I'm just using Internet Explorer and the pop-up blocker is disabled. In the title bar it says "message from webpage" and then in the body it does say "A PopUp was blocked" . Really dosnt seem to be any way to control it.

If anybody from Juniper is actually reading this consider this a much needed request for functionality in the next release.

Highlighted
Respected Contributor

Re: A PopUp is blocked

Which functionality are you referring to: SharePoint 2010 or Silverlight?

When you tested through JSAM, did you open a new browser instance to connect and confirm it is using that tunnel rather than the rewriter?

Highlighted
Occasional Contributor

Re: A PopUp is blocked

Sharepoint 2010.... with a tunnel open and opening a new browser session it works just fine. Only happens when in the rewriter.

Highlighted
Occasional Contributor

Re: A PopUp is blocked

Just to let you guys know - This is not Silverlight the popup is not done in Silverlight (tested on a box without Silverlight installed) so I'm going to reopen the call with Juniper. Will let you know if I get anywhere.

Regards Jon

Highlighted
Respected Contributor

Re: A PopUp is blocked

Hi destroyer,

Thank you for the information and confirmation; for Sharepoint 2010, I would recommend you contact your Juniper SE to check on this support. I am glad to hear this is working successfully through JSAM (I know it is not ideal).

@jonw: What was the solution provided on your ticket, do you mind unicasting to me?