cancel
Showing results for 
Search instead for 
Did you mean: 

Active sync timeout settings on the SA

Highlighted
Occasional Contributor

Active sync timeout settings on the SA

Hi everyone,

A customer of ours configured Active Sync to run over their SA but they claim that their Exchange server complains that the timeout for push mail isn't configured high enough. I've searched on the Juniper KB and I couldn't find anything where I could change the timeout on the SA itself. So could this be an option on the Exchange? Has anyone seen this error and knows how to fix this?

Thanks in advance

3 REPLIES 3
Highlighted
Frequent Contributor

Re: Active sync timeout settings on the SA

I'm not sure this setting is in affect for activesync settings. It would be interesting to know if it affects your issue.

First, create a User Role for Activesync. Edit the Activesynce Role and then edit Session Options. Here you can define Idle Timeouts and Max Session Lengths. Then you setup your virtual port for your activesync traffic, say: owa.domain.org and assign a public address. On the SA under Signing In, you create a New URL assign your vitual ports name and select the backend URL for your exchange client server. On this page you have an option to select role Option and assign it your Activesync role. I hope that is useful.

In our case the hangup was an ASA that had a default TCP session timeout of 5 minutes. Microsoft wants that set to 30 minutes to allow for the least number of Activesync refreshes. You also need to keep each routed hop in the loop in mind and check their TCP session timeouts.

Highlighted
Contributor

Re: Active sync timeout settings on the SA

You can change the time-out in the Web option of the role you created for Activesync:

1. Select your role under User Roles

2. Click the Web tab.

3. Click Options.

4. Click "View advanced options".

5. Enter the appropriate number os seconds in the HTTP Connection Timeout field (I used 540 seconds).

6. Click the Save Changes button.

Regards,

Russ

Highlighted
Occasional Contributor

Re: Active sync timeout settings on the SA

Thank you both for your answers.
I will post in this topic if it solved it.