cancel
Showing results for 
Search instead for 
Did you mean: 

ActiveX 30-second delay after upgrade to 7.0

Not applicable

ActiveX 30-second delay after upgrade to 7.0

After the upgrade to 7.0 there is a change made in the JuniperSetupClient push.

When the JuniperSetupClient was pushed out to users; there is a 30-second delay to allow users time to see the ActiveX prompt and accept it. Before the upgrade there wasn't a delay timer for this installation.

We don't want to close this installation automatically, is there a menu-setting or other setting where we can configure this timer?

Regards,

Mike Stokhof

2 REPLIES 2
Highlighted
Frequent Contributor

Re: ActiveX 30-second delay after upgrade to 7.0

There is no UI level setting to control the timer.

a brief note on why this 30 sec delay:

--------------------------------------------------------------------------------

If a client component such as HC, NC, WSAM, or WTS is configured for the user logging into an SA, the SA will attempt to download the setup installer that can then download the specific client component. For Internet Explorer browsers, the SA will attempt to install an ActiveX control to run the setup installer. When installing the Active X control, Internet Explorer will present a yellow bar for the end-user to accept the installation. The application will wait for 30 seconds for the end-user to accept the download of the Active X control. If the user does not have rights to download an ActiveX control or the end-user does not click on the yellow bar then the SA will fall back to Java to download the setup installer. If neither Java nor Active X control is enabled on the desktop then the end user will not be able to install individual client components.

If the Setup installer is downloaded successfully then the installer will try to run the Active X control. For Internet Explorer, installing and invoking an Active X control are two different operations and Internet Explorer presents a separate prompt for each of these operations. Therefore Internet Explorer will again prompt the end-user with the yellow security bar asking the end user if s/he would like to run the Active X control. The setup installer will again wait for 30 seconds before proceeding on to the login page. If the end user does not

click on this yellow bar then the login flow will direct the user to the SA home page. The next time the user logs into the SA, the user will again be presented the yellow bar and will have to wait for 30 seconds before being directed to the SA home page. Users must click on the yellow bar allowing the Active X control to run in order to avoid the delay each time they log into the SA.

The following permissions must be enabled on Internet Explorer for the user to avoid a 30 second delay each time she or he logs in:

1. Permission to install an Active X control or have Java installed.

2. Permission to run an Active X control.

The IE options which should be enabled are :- "Download signed ActiveX controls." and Run ActiveX controls and plug-ins."

Note: Restricted users who did not have the privilege to install an Active X control may have the privilege to run an Active X control.

-------------------------------------------------------------------------------

Contributor

Re: ActiveX 30-second delay after upgrade to 7.0

You should try 7.1. It has a much better handling of the ActiveX installation.