Showing results for 
Search instead for 
Did you mean: 

Assining a SSL (device) Certificate to a Cluster-VIP

Occasional Contributor

Assining a SSL (device) Certificate to a Cluster-VIP

Is it possible somehow? I've found that I can only assign certificates to virtual ports on either the external port or internal port, but not on a VLAN VIP.


Re: Assining a SSL (device) Certificate to a Cluster-VIP

There's no problem with it :-), works like a charm!

I'll let you know tomorrow how i did it, if not someone else does it before ;-)



Super Contributor

Re: Assining a SSL (device) Certificate to a Cluster-VIP


VLAN ports can be mapped to the device certificate. Once you create a VLAN port, the port will be displayed under VLAN ports option available in the Device certifcate under COnfiguration>Certficates>Device Ceryificatesof SA admin GUI.

There is no Virtual port option for a VLAN port.

A virtual port activates an IP alias on a physical port and shares all of the network settings (except IP address) with the internal or external port that hosts the virtual port. An IP alias is an IP address that is bound to a virtual port.

To create a virtual port for a standalone IC Series device:

In the admin console, select System > Network > Port Tab > Virtual Ports. The Port Tab could be for the internal or external port.To associate the virtual port with a device certificate, select System > Configuration > Certificates > Device Certificates.

Hope this clarifies your query. Please revert for any calrifications.

Please mark this post as 'accepted solution' if this answers your question that way it might help others as well



Occasional Contributor

Re: Assining a SSL (device) Certificate to a Cluster-VIP

If it's possible right away, then I don't know what I'm doing wrong. I've setup a active/passive cluster, then I've added a virtual system and created a new VLAN that I've assigned to that virtual system. After that I've imported a certificate to the root instance which I now want to assign to the vlan for the virtual system.

The problem is: The VLAN is not available for selection in "Configuration > Certificates > 'my certificate'".