cancel
Showing results for 
Search instead for 
Did you mean: 

Citrix Desktop Autolaunch

Highlighted
Contributor

Citrix Desktop Autolaunch

Spoiler
 

Guys,

 

I need your help on this one.

SA 4500 Cluster connected to Citrix Farm

I got the Citrix Desktop connection working by creating a TS Citrix profile but the customer wants a one click solution now.

Meaning now he has to click the link to his Citrix Desktop on the Home page and he has to click connect on the Java applet (Reason for using Java : he wants to be able to connect with a Mac)

What he wants is that once he logs in to the SSL VPN, that his remote desktop session is automatically launched. I tried setting the home page URL to the Citrix profile link but it won't launch. It just displays the default home page.

And after waiting a long time when trying to change the home URL it displays Unresolvable URL. This does not make sense at  all as it is a DNS name that it owns.

 

Can you help me with this one?

 

Thanks

 

K.

 

3 REPLIES 3
Highlighted
Frequent Contributor

Re: Citrix Desktop Autolaunch

If their environment permits, you may be able to configure a Web Resource profile as Citrix, define their Web-I  URL and XenDesktop servers, then configure the URL in the UI option to point to the Web-I .  I believe they can autolaunch the desktop from the Web-i itself. you will likely be expected to configure this resource for SSO into the Web-i.

Highlighted
Respected Contributor

Re: Citrix Desktop Autolaunch

is this something that is static or will the application/desktop change?

if it is static, you can enable "auto launch" in the bookmark definition if you are using CTS bookmarks (this is not available using VDI bookmarks)

Highlighted
Contributor

Re: Citrix Desktop Autolaunch

Hi Zanyterp,

 

I enabled Autolaunch on the bookmark but it still does not launch.

 

I have another problem as well where you guys maybe can help me.

 

I have tried to configure this also with the following scenerio :

 

First Auth Server is a Certificate Server and the second one an LDAP server.

 

There is a link between both using the Certserial and IP Phone (LDAP)

 

But the problem is that I seem not to be able to populate the correct username (USERNAME[2]) i presume) which results in citrix is not able to load any resources in that scenario.

 

What should the user variable set to?

And what about the password one?

 

I tried to configure the Citrix profile with a static test user for testing and this works, but as there has to be single sign on, I cannot keep this setup in place.

 

I do not seem to find the right variable to put in the User field of the profile.

 

Can you guys help?

 

Thanks,

 

Kristof