cancel
Showing results for 
Search instead for 
Did you mean: 

Connect 8.1r8.0 stopped working when I upgraded Debian 8 to Debian 9 (stretch)

Highlighted
New Contributor

Connect 8.1r8.0 stopped working when I upgraded Debian 8 to Debian 9 (stretch)

I've been using version 8.1r8.0 for a while now (since the next version up had a buggy installer) but when I upgraded Debian, it stopped working -- after connecting to the VPN, I couldn't even ping anything, let alone resolve DNS or browse the intranet.

 

Things I've tried:

 

- Modifying the 8.2r5.0 installer to pretend I'm using Ubuntu

- Using the 5.2r9.1 installer (did the version number go down when I wasn't looking?), again hacked to accommodate Debian (bypass dependency checking)

- Installed libwebkitgtk-1.0-0 and libwebkitgtk-1.0-0:i386 and messed around with LD_LIBRARY_PATH

- Tried to enable logging (-L 5, but I can't actually find any logs)

- Looked at `netstat -nr` output (yes, there's the tun0 device)

- Looked at iptables to make sure there weren't any weird rules

- Tried to download a newer version, but the packages aren't actually provided anywhere public

 

I'm pretty frustrated at this point. What can I even try next?

2 REPLIES
New Contributor

Re: Connect 8.1r8.0 stopped working when I upgraded Debian 8 to Debian 9 (stretch)

Moderator

Re: Connect 8.1r8.0 stopped working when I upgraded Debian 8 to Debian 9 (stretch)

Thank you for the update; I am glad to hear you found a solution that worked successfully