cancel
Showing results for 
Search instead for 
Did you mean: 

Couldnot bind to localport:xxxxx

Not applicable

Couldnot bind to localport:xxxxx

Hello,

 

I am trying to connect to my customers network. It uses JSAM and it was working for almost 2-3 weeks.

But one day suddenly I started getting message "Couldnot bind to localport:xxxxx".

I have checked in another machine, and it worked there. But after some days that too had issues.

I have even checked with our java team, since I could see many java applet exceptions, and concluded that I have to use old version of java (1.6 v). After cleaning up all existing java installations, I have installed 1.6 including jdk. and in the system where I was getting issue initially it worked.

 

But when I end the session and tried connecting again, same error popped up.

After that it never got connected from that machine.

 

Is there any solution of this.

2 REPLIES 2
Respected Contributor

Re: Couldnot bind to localport:xxxxx

It means that that port is already in use. For example if you are connecitng to port 80, you can't be running on a web server; if you are doing RDP, you can't have this option enabled on you rmachine and use the default port.

Please verify that the option to bind to another port is enabled on the JSAM connection definition. This will allow you to be redirected to a different local port that you will point your application to for the connection.

New Contributor

Re: Couldnot bind to localport:xxxxx

Zanyterp,

When using a 'Web Application Resource Profile' to configure JSAM to not use the CIE, is there any way to configure JSAM to automatically choose a different port from one to which JSAM is unable to perform binding?