cancel
Showing results for 
Search instead for 
Did you mean: 

Default URL behavior?

rswinter_
Frequent Contributor

Default URL behavior?

Not sure if this has been addressed before, but is ther a way to prevent users from being re-directed back to the main login page if they mistype the one they really want? We have a vendor login page that xome of them have a hard time typing (isn't not all that difficult, but still happens), so they are constantly getting put back to the default page, and then calling our help desk wondering why they don't have their normal permissions... I know I could just modify the default page "https://ive.mycompany.com" to say you've typed in the wrong url, but there are quite a few emploees who use that and I don't want to try to re-train them... Thanks. -Stephen
5 REPLIES 5
kktz_
Not applicable

Re: Default URL behavior?

I find this a pretty bad default behavior.  If this is the case there should be a checkbox to turn it off or something or to give a custom error message if the page doesn't exist.

I'm running into the same issues with vendors typing in the wrong URL and then trying to sign into our default corporate one.  Can anything be done about this with a new code?

cbarcellos_
Regular Contributor

Re: Default URL behavior?

Stephen,

 

That is the default operation of the IVE. Instead of showing a 404 message, the IVE will redirect the user back to the default URL:  ive.com/dana-na/auth/url_default/welcome.cgi

 

You could setup an IVS to keep the systems seperate. I looked into some other ways to work around this problem your users have... but an IVS looks like the best way to go.

rswinter_
Frequent Contributor

Re: Default URL behavior?

IVS? Would that be setting up a different FQDN? https://ive-vendors.mycompany.com, or are you referringto something a little different?
cbarcellos_
Regular Contributor

Re: Default URL behavior?

It is different from FQDN. I tried using FQDN in my lab, but it also forwards back to the default URL if a invalid URL is typed in.

 

IVS: Instant Virtual System: Page 883

 

http://www.juniper.net/techpubs/software/ive/6.x/admin/6.5-IVEAdminGuide.pdf

 

This would give you a seperate virtual system on the IVE. While not the cleanest solution, it should work. You could also ask your sales engineer to file a feature request to add a configuration option to disable the 404 redirect to the default URL.

ruc_
Regular Contributor

Re: Default URL behavior?

You can minimize the impact of this issue by having 2 different FQDN's like you indicated in your earlier post.

ssl-vendor.companyX.com and ssl.companyX.com and to avoid the certificate warning you can associate the new FQDN with an IP on a Virtual port