cancel
Showing results for 
Search instead for 
Did you mean: 

Expanded browser support for HC

Highlighted
Occasional Contributor

Expanded browser support for HC

Are there any plans to pursue expanding support for different web browers for HC? I've often base role-mapping decisions on HC information/results, and I've been finding that users that have their browers upgraded automatically (Firefox 3.6 in particular) find themselves unsupported by HC. Google Crome is another browser that comes to mind.

4 REPLIES 4
Highlighted
Contributor

Re: Expanded browser support for HC

Hello,

This is indeed an interesting question...

You can find the Qualified / Compatible platform list including the base Operating System and Browser for various IVE components including Host Checker in the download area of Juniper website, "Secure Access Supported platforms" for example the 6.5 version is here

As defined in the document, Qualified / Compatible platform means:

Qualified Platform
The platforms listed in the qualifiedÓ category have been systematically tested by QA department as part of the release covered by the Supported Platforms document.


Compatible Platform
The platforms listed in the compatibleÓ category have not been systematically tested by our QA
department in this release but based on testing in previous releases and knowledge of the platform Juniper expects that the functionality will work and will fully support these platforms.

Of course that scope has to be limited somehow because number of test to run increases exponentially with every new OS / Browser / version added.

Another reason being, in case of new browser versions (Firefox 3.6 for example), these newer versions might not be available at the time of the initial release of IVE OS.

So this is it for the "official" guidance.

Now... you might actually find out that several OS/Browser combinations that are not in the Qualified / Compatible platform list, actually also work. But there might be some caveats, or some things that do not work as expected.

I would distinguish 2 scenario:

1 - Base OS and browser/JRE are in the Qualified / Compatible list but not with exact version:

For example Firefox 3.6 on Windows OS falls in this category. If the changes from previous release were not too radical, there you might find out that most if not all of the functionality works. I personally use Firefox 3.6, with Host Checker, Network Connect, Secure Meeting and I haven't came across any major issue. Searching for customer reported issues with Firefox 3.6 I don't see anything serious either. So if you come across a specific issue withe a OS/browser combination that is "quite close" to something officially supported, it is worth opening a JTAC case so that we can look into the problem and we'll certainly try to adress it on a "best effort" basis. We also had a few instances in the past where a minor browser or JRE upgrade caused some issues but these were immediately addressed in the following IVE OS maintenance release.

2 - Unsupported OS/Browser:

For example, we have seen some requests to support Firefox on Mac OS. Although this is currently unsupported, you might find that some of the functionality work, so depending on what features are used, this might work for you. But depending on the actual issue, you might be advised to revert to a supported/tested platform.

Google Chrome also falls in this category. Currently Chrome isn't even included in the Qualified or Compatible platform list. Again, some functionality might work and some not. For example, Host Checker does not even launch with Chrome and you will find a log message like this in User access logs:

Browser on host 172.26.124.90 is not supported for Host Checker or Cache Cleaner: User agent Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/532.5 (KHTML, like Gecko) Chrome/4.1.249.1045 Safari/532.5.

In this case, it is best to contact your local Juniper Sales team and ask for "New feature request".

If we see enough demand for a specific browser / OS, then we will certainly consider adding it in the future.

Thanks,

Lionel Chilaud (JTAC)

Highlighted
Occasional Contributor

Re: Expanded browser support for HC

Thanks for the reply Lionel. Firefox on Mac OS is indeed the primary subject of my post. (I can't stand using Safari.) I was having success with HC & Firefox 3.5 on Mac 10.6, but once Firefox updated to 3.6 that stopped working for me.

Highlighted
Occasional Contributor

Re: Expanded browser support for HC

This is definitely on our radar and at some point, we will qualify it "officially".
Highlighted
New Contributor

Re: Expanded browser support for HC

Hello,

This hasn't been updated in awhile - are there plans to fix the host checker with Chrome? I'm running 7.1R1 (build 17675) but still no joy...

Any update would be appreciated.

Many thanks!