cancel
Showing results for 
Search instead for 
Did you mean: 

FIPS in Software for MAG -SA and VA devices

Highlighted
Occasional Contributor

FIPS in Software for MAG -SA and VA devices


The Junos Pulse Secure Access Service (SSL VPN) 7.4 offers support for FIPS as a sofware option in MAG devices.

 

We offer FIPS level 1 support starting with Secure Access Service release 7.4 . The SA device uses a 140-2 level 1 certified cryptographic module to comply with FIPS. When FIPS level 1 support is enabled applications, such as browsers, accessing the web server must support Transport Layer Security (TLS), the latest version of Secure Socket Layer (SSL).

If the platform features hardware acceleration, then for SSL processing SSL hardware acceleration is disabled as hardware acceleration does not comply with FIPS validation.

Only FIPS approved algorithms are used when in FIPS level 1 support is enabled.

 

If you have any queries regarding this feature, please let us and and we will try to address those at the earliest.

3 REPLIES 3
Highlighted
Frequent Contributor

Re: FIPS in Software for MAG -SA and VA devices

What's the user capacity impact of enabling FIPS on a MAG device?

 

Thanks

Highlighted
Frequent Contributor

Re: FIPS in Software for MAG -SA and VA devices

It also shows in the GUI System>Configuration>Security> Enable FIPS Mode- *Additional License purchase required" But I can't find any FIPs licensing on the pricesheet and I was able to enable it and it's not complaining about a missing license.

 

Thanks

Highlighted
Occasional Contributor

Re: FIPS in Software for MAG -SA and VA devices

Enabling FIPS will not have impact on user capacity ...

Currently we do not enforce requirement of FIPS license to have software FIPS feature enabled. For more details I suggest you to contact our Account team/PLM.