Showing results for 
Search instead for 
Did you mean: 

Failed to download the application (Mac)

Occasional Visitor

Failed to download the application (Mac)

Hi, I use Pulse Secure on Mac to connect to my organization.

Because of, Pulse Secure stopped working. 

I could not execute the uninstaller in  "/Library/Application\ Support/Pulse\ Secure/Pulse/" because OS refuses to open it.


I tried to upgrade the client by accessing the VPN. It downloads and installs the "Pulse Secure App Launcher", but then the "Pulse Secure Setup Client" fails to validate the file integrity:




DSVerifyHelper::validate()' SecStaticCodeCheckValidity failed. (filename=/Users/xxx/Library/Application Support/Pulse Secure/SetupClient/, status=-67050)^M


DSVerifyHelper::validate()' SecStaticCodeCheckValidity failed. (filename=/Users/xxx/Library/Application Support/Pulse Secure/SetupClient/pulseSetupDll.dylib, status=-67050)^M


I tried removing the  "~/Library/Application Support/Pulse" Secure folder several times, and the result is the same.

I probably could fix the issue by installing the latest Pulse Secure Client directly. However, I cannot find the dmg file, and requires an RTU or RMA code.


Any help would be appreciated.