cancel
Showing results for 
Search instead for 
Did you mean: 

Google Chrome starts slowly/delayed when the VPN connection is NOT established by Network Connect

Highlighted
New Contributor

Google Chrome starts slowly/delayed when the VPN connection is NOT established by Network Connect

When I am connected via VPN and the Juniper Network Client with my company network my browser Chrome starts in 2 seconds and I can surf in the internet immediately. If the VPN is not established I have to wait about a half minute until I can open any URL.  It feels as if Chrome is waiting for a network resource and is going on after an idle time of a half minute. I have this problem on different company computers!

 

Has anyone an idea? Thank you in advance!

 

Markus

5 REPLIES 5
Highlighted
Super Contributor

Re: Google Chrome starts slowly/delayed when the VPN connection is NOT established by Network Connect

Hi,

 

Are you connected using ESP or SSL transport mode?

 

Is port 4500 udp open on the firewall to the SA/MAG ?

 

Regards,

Jay

Highlighted
New Contributor

Re: Google Chrome starts slowly/delayed when the VPN connection is NOT established by Network Connect

Hello Jay,

 

thank you for your help!!! :-)

 

Are you connected using ESP or SSL transport mode?

=> Transport mode is ESP, Security AES128/MD5, and Compression LZO

 

Is port 4500 udp open on the firewall to the SA/MAG ?

=> I am using a standard Windows 7 firewall. So I have added an incoming rule to allow connection to port 4500 UDP and an outgoing rule for the same. But this makes no difference: I start Chrome and after waiting for 31 seconds I can start browsing. So I removed the rules again.

 

Kind regards,

 

Markus

Highlighted
New Contributor

Re: Google Chrome starts slowly/delayed when the VPN connection is NOT established by Network Connect

Forgot: There is no special rule for port 4500 UDP.

And thatÕs for sure: If the machine is connected to the company network via Juniper Network Connect, Chrome is up and running like IE immediately.

Highlighted
Super Contributor

Re: Google Chrome starts slowly/delayed when the VPN connection is NOT established by Network Connect

seems like a chrome issue as issue does not occur with IE,what about on a PC with no network connec clientt software installed, does the same issue occur?

 

Regards,

Jay

 

 

Highlighted
New Contributor

Re: Google Chrome starts slowly/delayed when the VPN connection is NOT established by Network Connect

Correct, it is a Chrome issue in association with Network Connect. With IE or Firefox I do not have this effect. Chrome works fine on clients that have Network Connect not installed. But I need the Juniper SW to connect with the company network and it is hard to go without Chrome when using Android devices. :-(
I am using both Network Connect and Chrome since years, but I do not get rid of this inconvenience.

 

Thank you Jay!