cancel
Showing results for 
Search instead for 
Did you mean: 

Host Checker incorrectly validating wrong realm

Occasional Visitor

Host Checker incorrectly validating wrong realm

Hello,

We have two realms set up.

  • Company Users
  • IT Only

We have a single host checker ("Company Host Checker") set up that looks for this:

  • Windows/Mac
    • BitLocker encryption (for Mac, it'll check for FileVault)
    • User certificate
    • Antivirus full scan age (within 7 days)
    • Antivirus update age (within 2 days)

For the "Company Users" realm, we have password authentication and host checker enabled.

For "IT Only" realm, we only have password authentication enabled.

 

However, when I try to connect to the "IT Only" realm, it still tries checking against the Host Checker. It would still connect successfully, but say that it is limited.

 

What is the problem? Did I do something wrong, or is that a bug? I'm trying to set up a third realm (and add a new host checker) for some company partners, but this bug/issue is giving me a headache.

 

Few things to note:

* Host checker is not enabled on the role-level.

* I have already ran a test with creating a third realm with their own host checker ("Partner Host Checker"). In that realm, I enabled the "Partner Host Checker". However, now it tried checking the original host checker ("Company Host Checker"), and the new "Partner Host Checker".

* I thought that maybe re-using roles within different realms can be the cause, so I created a new role and attached it to the new realm. Heck, I even disabled host checker. It still tried checking the original "Company Host Checker".

 

How do I solve this?

1 REPLY 1
Moderator
Moderator

Re: Host Checker incorrectly validating wrong realm

Do you have two realms mapped to the same sign-in URL?

 

If yes, then it expected to see the host checking process. Please map the user realms to a separate sign-in URLs and check the behavior.