cancel
Showing results for 
Search instead for 
Did you mean: 

How to configure SA to use Junos Pulse?

SOLVED
Highlighted
Occasional Contributor

How to configure SA to use Junos Pulse?

Recently, I am thinking that I want to try to use Junos Pulse using my iphone but I don't know how to do it. I prepared SA series which is running IVE 6.4R1 or later, and iPhone, and Junos Pulse client from iTune store.

How can I set SA for Junos Pulse Gateway? Is there any documentation about how to?

Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Contributor

Re: How to configure SA to use Junos Pulse?

For Pulse on iPhone, you don't need the SA to be on 7.0

Requirement is

>> IVE OS 6.4 or above on the SA,

>> iOS 4.1 on the mobile device

Ref:

http://www.juniper.net/techpubs/software/pulse

Junos Pulse + Junos Pulse on Apple iOS Administration Guide

> Chapter 9 pp 84

On the SA, setup access as you would for Network Connect.

The admin guide includes the step-by-step procedure, incl. optimised sign-in pages.

Note: answer only applies to Junos Pulse on iPhone.

Regular Pulse client for Windows requires IVE OS 7.0 or above

View solution in original post

22 REPLIES 22
Highlighted
Contributor

Re: How to configure SA to use Junos Pulse?

You need to be running IVE 7.0R1 (or later). You can find instructions at: http://www.juniper.net/techpubs/software/pulse/guides/j-pulse-1.0R1-adminguide.pdf.

Regards,

Russ

Highlighted
Contributor

Re: How to configure SA to use Junos Pulse?

For Pulse on iPhone, you don't need the SA to be on 7.0

Requirement is

>> IVE OS 6.4 or above on the SA,

>> iOS 4.1 on the mobile device

Ref:

http://www.juniper.net/techpubs/software/pulse

Junos Pulse + Junos Pulse on Apple iOS Administration Guide

> Chapter 9 pp 84

On the SA, setup access as you would for Network Connect.

The admin guide includes the step-by-step procedure, incl. optimised sign-in pages.

Note: answer only applies to Junos Pulse on iPhone.

Regular Pulse client for Windows requires IVE OS 7.0 or above

View solution in original post

Respected Contributor

Re: How to configure SA to use Junos Pulse?

If you are already using Network Connect, allow your user to signin to that realm/role mapping group and you should be good-to-go.

Highlighted
Contributor

Re: How to configure SA to use Junos Pulse?

For iPhone access it's much nicer to use the custom sign in pages. Makes for a nice, clean sign-in page.

I just created a new login page (ssl.foo.com/m/) that uses this template file. Easy.

You can get this template off a 7.0 server (see kb below) and they also upload fine on a 6.5 (and probaly 6.4) SSL VPN too.

kb article...

http://kb.pulsesecure.net/index?page=content&id=KB17749&smlogin=true

Highlighted
Frequent Contributor

Re: How to configure SA to use Junos Pulse?

I'm trying get iPhones and iPads to connect to the SA and I have followed the documentation at this link exactly:

http://www.juniper.net/techpubs/software/pulse/guides/j-pulse-1.0R2-adminguide.pdf

I always get "The request timed out". Smiley Sad

I noticed that the version of Junos Pulse app from iTunes store is now 2.0.0.8059. Does that make a difference?

Highlighted
Respected Contributor

Re: How to configure SA to use Junos Pulse?

I am sorry to hear that; what does your user access log say or is the failure in the connection attempt to the SA so there would be nothing in the user access log? Is there anything in the events log, maybe?

The Pulse version shouldn't have an impact on if you can connect; but it might be worth it.

Are you using name or IP? Default URL? Is the connection defined as https://<yourIVE> or Https://<yourIVE>? If the latter, can you try the former?

Highlighted
Frequent Contributor

Re: How to configure SA to use Junos Pulse?

I uploaded the custom sign on page for Apple iOS and now it connects. Noticed a couple of things though:

1. My Intranet bookmarks (OWA etc.) don't work. It tries to rewrite them and they never load, just timeout. I can go to the homescreen though and use Safari to open my OWA page directly. Even when I make the bookmark to explicitly NOT rewrite, it does.

2. It seems to have problems with disconnecting. My session stays in the SA, even if I choose disconnect in Junos Pulse.

Highlighted
New Contributor

Re: How to configure SA to use Junos Pulse?

Hi there,

I'v been able to configure everything from the SA side to use Junos Pulse with my iPhone.

The problem i have now is that when i launch the VPN (junos pulse) on my iPhone, the SSL VPN layer not seem to activate (the little VPN logo in the status bar).

So, all i can do now, is those URL i'v setup in the role.

I want, if it's possible to have acces to VPN even with ssh terminal et safari standalone browser or any other external app on my iPhone.

Anyone can help me out on that one, what i just miss as configuration ?

thank's in advance !

Martin C.

Highlighted
New Contributor

Re: How to configure SA to use Junos Pulse?

reply to myself

forget about my post, i'v successfuly configure everything from here: http://www.juniper.net/techpubs/software/pulse/guides/j-pulse-1.0R2-adminguide.pdf

section where they talk about SA Installation (at the end of the document)

SSL VN L3 working just well and now i can SSH and RDP servers on my server side network, woooooooow

pretty impressive !!

cya soon !!