cancel
Showing results for 
Search instead for 
Did you mean: 

IVE and WEB-Ressource (Java) for Citrix WEB-Interface 4.6 does not work with outside clients

arsch_
Occasional Contributor

IVE and WEB-Ressource (Java) for Citrix WEB-Interface 4.6 does not work with outside clients

Hi,

i have a SA-2000 with only one Interface in a DMZ.
I published a WEB-Ressource with Citrix-Templates (JAVA) for Connection
to a WEB-Interface 4.6 and my Shared Applications. The nessesary ACL's inside

IVE a allready set.

My Firewall-Policy is set proper and works well for the nessesary IP's and Ports.
I can ping the internal Ressources from the IVE and DNS-Resolve will work.

Connection to the WI works and Running the Shared Applications via
WEB-Interface from a internal PC works too.

But if I use the IVE for this Ressource from outside (the internet)
it does not work and I get an error "Can't connect to the Citrix MetaFrameServerBrowser".

Does Anybody have a Solution for this or an Idea ?



Message Edited by arsch on 12-17-2008 04:01 AM
4 REPLIES 4
Jickfoo_
Super Contributor

ÿ"Re: IVE and WEB-Ressource (Java) for Citrix WEB-Interface 4.6 does not work with outside clients"

When you run it from an internal PC are you sure the traffic isnt just going to the resource itself and not through the port forwarder ?

Are your sure the name resolution of the server name field is set up properly in the applications parameters area ?

Under resource policies, are you certain the resources have been set up to properly allow access (again, name resolution is important here, I'd suggest adding the IP of the device you want to port forward to as well) ?

Under Resources try adding 10.x.x.x:*

arsch_
Occasional Contributor

Re: IVE and WEB-Ressource (Java) for Citrix WEB-Interface 4.6 does not work with outside clients

When you run it from an internal PC are you sure the traffic isnt just going to the resource itself and not through the port forwarder ?

Yes traffic goes to the resource via the firewall.

Are your sure the name resolution of the server name field is set up properly in the applications parameters area ?

Nameresolution works fine. I can resoled allSystems (WI, MetaframeServers) from the IVE.

Under resource policies, are you certain the resources have been set up to properly allow access (again, name resolution is important here, I'd suggest adding the IP of the device you want to port forward to as well) ?

Yes, I have set the global Net's like 10.1.1.x:* and 10.1.2.0:*

Under Resources try adding 10.x.x.x:*

I don't understand what happens if I use the WEB-Interface. Other Applications will run well from outside.

Does Anybody have a Document "HowTo setup a WEB-Interface for using it with IVE" ?

ESpa_
Occasional Contributor

Re: IVE and WEB-Ressource (Java) for Citrix WEB-Interface 4.6 does not work with outside clients

Citrix web-interface will step out of the process as soon as you have your icons presented to your browser.

The ways to get around that are to either configure SAM of run it via Juniper CTS.

sobsidian_
Not applicable

Re: IVE and WEB-Ressource (Java) for Citrix WEB-Interface 4.6 does not work with outside clients

Is there any way to have the java client, without the need for NC or SAM? Im onsite with a customer and they mentioned it was working before with version 6.4R1.0 however we downgraded to 6.3R4.0 because we do not want to be on the first Rev of code. I have yet to anything in the forumns about doing this.