cancel
Showing results for 
Search instead for 
Did you mean: 

Is there any issue using 9.x client with 8.3.x PCS?

Contributor

Is there any issue using 9.x client with 8.3.x PCS?

I didn't see this mentioned in the supported OS doc.  Can I use the 9.x clients?  Would like the built-in browser for SAML auth and RS4 support.

7 REPLIES
Moderator

Re: Is there any issue using 9.x client with 8.3.x PCS?

Hi Smartd,

 

You can use the 9.x client with 8.3, however, you'll need PCS 9.0 to turn on the ability to use the embedded browser for SAML.


Here's the config snippet:Screen Shot 2018-06-18 at 10.19.18 PM.png

 

 

This is the Connection Set client behavior part of the PCS config.  You may be able to do it using a preconfig file, but you'd still need PCS 9.0 to generate the preconfig file.

 

Regards,

Ashur

Please remember to mark solved once the thread is resolved. Kudos are also appreciated.
Tags (2)
bmi
New Contributor

Re: Is there any issue using 9.x client with 8.3.x PCS?

 

Hello,

Is there any chart showing version’s compatibility between Clients and PCS?

I’ve looked for such information in the documentation but without any results.

We are using PSA-5k with the 8.3R5.1 firmware and we are preparing for upgrade to the 9.0R2.1 version. The initial tests of 9.0R2.1 Client with our PSA-5k are unsuccessful, so at this point we don’t know if this is a specific notebook/OS issue or a general incompatibility.

The best upgrade scenario for us is to upgrade as many Clients as possible in the first step, and then the PSA-5k in the second one.

TIA and best regards,

bmi

New Contributor

Re: Is there any issue using 9.x client with 8.3.x PCS?

Exactly what I would like to know also...

 

(in my case: can't place 9.0 on a MAG2600, but the download site suggests it can...)

Error on upgrade attempt: "Step 5: This hardware platform is not supported by software version 9.0R2.1 Build 63975 ... complete (0 seconds)"

bmi
New Contributor

Re: Is there any issue using 9.x client with 8.3.x PCS?

In the Relese Notes for 9.0R2.1 there is a section about supported platforms:

You can install and use this software version on the following hardware platforms:
PSA300, PSA3000, PSA5000, PSA7000F, PSA7000C

Unfortunately, there is no MAG2600.

New Contributor

Re: Is there any issue using 9.x client with 8.3.x PCS?

Thanks for clarifying. Smiley Happy

 

Does this mean MAG2600 will get no more updates in the 8.x range / is it EOL?

bmi
New Contributor

Re: Is there any issue using 9.x client with 8.3.x PCS?

Community Manager

Re: Is there any issue using 9.x client with 8.3.x PCS?

Hello All,

 

Thank you for the feedback.  We will provide this feedback back to the product teams about a compatibility matrix.  

 

As a general rule of thumb, it will depend if the new feature has any server dependencies or not.  In the case with the embedded browser, the option to turn on/off is dependent on the server.  However, any supportability type issues like Windows 1803 or Mojave support (macOS) are mainly client-side components and you can simply upgrade the PSD client software without the need to upgrade the server (PCS) software.

 

For MAG hardware, 8.3RX will be the last software version.  Pulse Secure will continue to provide "best-effort" for critical security patches until the end of the hardware.