cancel
Showing results for 
Search instead for 
Did you mean: 

JSAM "cannot bind to localport=80"

Occasional Contributor

JSAM "cannot bind to localport=80"

Hi,

For Sharepoint-access, we are using JSAM, with local:loopback port 80.

One user had an error "cannot bind to localport=80", and I found that Skype was the guilty process.

But now I have another user with the same errormessage, and when running tcpView.exe (which is supposed to list all processes on windows including which ports they occupy), no process seems to be using port 80.

Anyone have any idea? What might be occupying port 80, without showing in the tcpView-process-list?...

Thanks! Smiley Happy

8 REPLIES 8
Frequent Contributor

Re: JSAM "cannot bind to localport=80"

I know this doesn't directly answer your question... but why are you using JSAM instead of WSAM? In the 3 years I've been an IVE admin I've never had anything but trouble using JSAM and always found WSAM to be far superior and easier to use. The only reason not to use WSAM is if your users aren't running Windows... but since you're giving them Sharepoint access I'd assume they all are running Windows, am I right? I'm almost positive your issue is specific to JSAM, so if you can switch to using WSAM to give this access you wouldn't have this problem.
Contributor

Re: JSAM "cannot bind to localport=80"

Kath,

I'm using the Microsoft Sharepoint web profile template to intermediate Sharepoint (Resource Profiles>Web>New Profile>select Microsoft Sharepoint as the type from the drop-down). This has worked well for us; you may want to try that instead of JSAM. On another note, we use JSAM exclusively in a healthcare environment with external DNS loopback resolution instead of host file modification. Macs are popular with physicians and JSAM keeps cross-platform options open. :smileywink:

Contributor

Re: JSAM "cannot bind to localport=80"

I have seen this problem when a web server was running on the user's computer. They were running IIS. However I would recommend using the Sharepoint Web Resource Profile if you can.
Occasional Contributor

Re: JSAM "cannot bind to localport=80"

Thanks for all the input Smiley Happy

We use JSAM as the customer supposable needs support for MACs as well. But as far as I can see the only fully supported browser for sharepoint is IE, so this is actually a bit of a self-contradiction. I have thought about recommending the change to WSAM as I agree that there seems to be fewer problems with it.

We also tried the Microsoft Sharepoint web profile template but the problem with it is that it rewrites the URL's. Customer demands that the URL's must not be rewritten, as they shall be able to click on sharepoint-links from emails etc that opens new browser sessions..

Frequent Contributor

Re: JSAM "cannot bind to localport=80"

Wow, the client sure tied your hands with this one didn't they? While you may be able to find the issue with this specific user, you know that this will keep popping up you'll continue to have to spend time and resources on other users because of this. My recommendation would be to go to the client and make them choose which feature is more important: Support for Macs, or not rewriting, because it doesn't look like you'll be able to do both effectively without causing a lot of headaches and wasted time troubleshooting. If they value Mac support more, rewrite the site. If they value rewriting more, use WSAM. Or... you could offer both. If you're a Mac user you have to go to URL #2 to view the rewritten version, if you're a Windows user go to URL #1 and use WSAM. Something tells me their # of Mac users is pretty low anyway, so this may be the best way to satisfy everything.
Super Contributor

Re: JSAM "cannot bind to localport=80"

Couldn't you create two roles, one using JSAM and one using WSAM, and send users using IE to the WSAM role and everyone else to the JSAM role? I don't think you have to hamstring all your users to maintain flexibility for a few.

Ken

Occasional Contributor

Re: JSAM "cannot bind to localport=80"

Thanks again Smiley Happy

I agree on your input, -it seems that having separate roles or urls will be the best solution.

Highlighted
Occasional Contributor

Re: JSAM "cannot bind to localport=80"

Hi,

I may be far in time, but the solution is the checkmark located in the JSAM policy to allow a new port to be added to the client if the client port (ie. 80) is being used.

Thanks