cancel
Showing results for 
Search instead for 
Did you mean: 

Junos Pulse 5.0r1 seems to break MS Surface Tablet

New Contributor

Re: Junos Pulse 5.0r1 seems to break MS Surface Tablet

I just finished trying Pulse client 5.0r3 on my Surface Pro. Pulse would not connect to any SA/MAG and I lost the ability to browse or otherwise connect to the network.

 

My testing comprised a full factory reset on the Surface Pro to windows 8, apply all Windows updates, updated to Windows 8.1 and apply all windows updates. Install Firefox and Java, in that order.

 

I was not able to install the Pulse 5.0R3 client from my V7.4 SA. Only the client setup app would appear to run but no client install actually occured. I downloaded the 5.0r3 64bit msi file and ran the install. The client installed but would not connect to either SA/MAG I tested against.

 

I am resetting the device again and will try it with the KB28571 workaround and post more if that works.

New Contributor

Re: Junos Pulse 5.0r1 seems to break MS Surface Tablet

I've been meaning to update this thread...

 

Here's the order-of-installation that I have found to be successful to install Pulse with Hostchecker and enjoy full Type cover and Touchscreen functionality:

 

1) Reset the Surface back to OE settings (note: you'll lose everything on your drive, so backup stuff if needed):

 

a. Plug into AC power

b. Swipe in from the right side

c. Go to Settings, Change PC Settings, Update and recovery, Recovery

d. Within Remove everything and reinstall Windows, choose Get started

e. Follow the Wizard to re-install Windows

 

2) Once Windows has been reinstalled and your personal settings configured, go to the Desktop

 

3) Install all Windows updates, including Firmware updates

 

4) Download Junos Pulse Bulk 64 Bit Installer MSI build b41197: https://www.juniper.net/support/downloads/?p=pulse#sw

 

5) Install version b41197 of Pulse, running the executable as Administrator. Don't Reboot. If you do accidently reboot, you will have to start over from Step 1.

 

6) Follow steps 2 thru 7 from this KB: http://kb.pulsesecure.net/InfoCenter/index?page=content&id=KB28571&smlogin=true

 

In case you can't access the KB, here are those steps:

 

2. Download the 64-bit nvspbind package from the following site: http://archive.msdn.microsoft.com/nvspbind/Release/ProjectReleases.aspx?ReleaseId=3837

 

In case Microsoft removes the archive, you can grab NVSPBIND from here: http://1drv.ms/1gilvk8


3. Run Nvspbind_package.EXE as Administrator It will prompt for a target folder to extract the package contents.

 

4. Open a command prompt (run as administrator).

 

5. cd to the folder where the Nvspbind_package.EXE is installed.

6. Run the following command: nvspbind.exe -d * jnprna

7. Run the following command: nvspbind.exe -e "Microsoft Wi-Fi Direct Virtual Adapter" jnprna

After a reboot, the tablet should run properly.

 

From a serious amount of testing, I've only been able to get b41197 of Pulse working. Here's Help, About showing my Pulse Version Details:

 

Pulse1.PNG

 

Pulse2.PNG

New Contributor

Re: Junos Pulse 5.0r1 seems to break MS Surface Tablet

You beat me to it...

 

I had to use this same process for Pulse 5.0r3 and it worked as desired. I now have a functioning pulse client on my surface pro tablet running windows 8.1.

 

 

Highlighted
Occasional Contributor

Re: Junos Pulse 5.0r1 seems to break MS Surface Tablet

Weird because since 5.0 R3 came out in order mainly to fix that Surface incompatibility issues.

 

I've used the method identified above with 5.0 R1 successfully unbinding all network adapters and just binding it to the wifi adapter of the surface but now that 5.0 R3 is out, I don't have to do anything special after the install and it works fine.

 

I do use a Surface Pro 2, if that makes a difference and I've reinstalled windows from scratch on two difference surface and it works fine for me.

 

The nvpsbind thing shouldn't be required anymore since Juniper switched from NDIS5 to NDIS6 and it's not required to do this anymore since it should work out of the box.

 

That being said, I'm using the standalone installer(MSI) and haven't tried installing directly from the IVE.

 

I'm also using IVE 7.3R1 right now on SA6500 boxes.

New Contributor

Re: Junos Pulse 5.0r1 seems to break MS Surface Tablet

I would have to agree that the MS workaround should not be required. I was surprised when I did the standard install using the msi file on a freshly rebuilt and patched win8.1 and after reboot pulse did not work and the device was not operating properly. I also had some problems installing from my 7.4R? DTE IVE in my home lab.

 

I am opening a tac case so I know what the specifics are around this issue. Perhaps it is the HW and driver differences between the Pro and Pro2...or it is just me...Smiley Tongue

Contributor

Re: Junos Pulse 5.0r1 seems to break MS Surface Tablet

This issue is now fully resolved with Pulse 5.0R3 (using NDIS6 instead of NDIS5).

 

See http://kb.pulsesecure.net/InfoCenter/index?page=content&id=KB28571 for details

 

 

Frequent Contributor

Re: Junos Pulse 5.0r1 seems to break MS Surface Tablet

I can confirm on my test unit that the new client works on a Surface 1.

New Contributor

Re: Junos Pulse 5.0r1 seems to break MS Surface Tablet

Hello all. I'm trying to install Pulse Secure 5.3r4.1 on a windows 10 Surface Book and I'm losing all internet as soon as its installed.

Is there any chance my issue is related to this thread?

Moderator

Re: Junos Pulse 5.0r1 seems to break MS Surface Tablet

It could be; but most likely, it is not
Do you have any virtualization software installed?