cancel
Showing results for 
Search instead for 
Did you mean: 

Junos Pulse - WSAM not connecting

Highlighted
Frequent Contributor

Junos Pulse - WSAM not connecting

I am trying to migrate my users away from the legacy WSAM to using WSAM via Junos Pulse. But things do not seem to be working correctly. My users still like the web page with the bookmarks, so we have to keep it. I have installed JP from MSI ahead of time, and configured the role to use WSAM and checked the box for "deliver via Junos Pulse". When I log in it creates a connection on the Junos Pulse client, but cannot connect. Upon examination, it autocreated the URL without the https:// so its only the IVE hostname. I am able to repeat it. If I manually create a connection to https://vpn.domain.com, I can connect and get WSAM roles. What am I doing wrong?

 

IVE OS 8.0R7 / Junos Pulse 5.0R7

6 REPLIES 6
Highlighted
Valued Contributor

Re: Junos Pulse - WSAM

Hello Deacon,

 

The URLs are associated with a connection set under the Junos Pulse > Connections.  Select the corresponding connection set and it should list all of your connection at the bottom of the page.  Click on the connection name and it should have a field for "URL".

Highlighted
Frequent Contributor

Re: Junos Pulse - WSAM

I looked at that, and defined it as https://... but it still does it without on the client. Anyways, I thought that part of the config really only applied if you have full VPN Tunneling enabled?

Valued Contributor

Re: Junos Pulse - WSAM

Are you modifying the URL or the connection name?  The connection name is what appears in Junos Pulse and this is just a friendly name.  If you go into the details for the connection it should say "Server URL: <URL>".

Highlighted
Frequent Contributor

Re: Junos Pulse - WSAM

The connection that populates on the client just says vpn.domain.com for the URL and the Name.It says nothing else. I've checked both in the IVE. I even went into the JP connection config on the IVE and changed the connection Name to something unique like "JP WSAM" and deleted all client connections in Windows. Logged back on to the site, it re-creates the connection in the JP client as vpn.domain.com. No https:// in the URL at all and just sits there trying to connect. If I turn off "deliver via Junos Pulse" the legacy WSAM launches and connects just fine. Also, if I assign a role with full VPN tunneling, it works fine as well.

Highlighted
Valued Contributor

Re: Junos Pulse - WSAM

I would assume if it was an issue with the URL, VPN tunneling would not work either.  What do the debuglog state?  Do you see a connection being made?  Do you have a case open with the debug log attach so I can review?

Highlighted
Frequent Contributor

Re: Junos Pulse - WSAM

It gets stranger. I changed the role/VPN tunneling config to use Default/Default for JP Config/Conn Set (VPN tunneling option still unchecked in role) and it works just fine and creates the right URL. I duplicate the exact JP Config/Conn Set with custom name and same URL ect. and it fails.