cancel
Showing results for 
Search instead for 
Did you mean: 

Junos Pulse - empty window (Win 7, 64-bit)

New Contributor

Re: Junos Pulse - empty window (Win 7, 64-bit)

Updates would be appreciated. I don't have total control over the laptop that is experiencing the issue so I can't re-image or do extensive troubleshooting with the laptop.

If anyone finds steps for a fix updating the thread would be appreciated.

Occasional Contributor

Re: Junos Pulse - empty window (Win 7, 64-bit)

I have a fix!!! At least for all of my users that have been experiencing this issue. See the following:

1. Recieved instruction to delete %windir%\inf\infcache.1

2. Noted that the file didn't exist!

3. Did some searching on Google and found that the registry for the creation of the driver cache is supposed to be the following:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion the value 'DevicePath' should point to '%SystemRoot%\inf'. Additional items, separated by semikolons, are ok but '%SystemRoot%\inf' has to be one of them and first in line.

4. This entry was not in the registry, it was pointed to a folder which contained a different software product called "SafeCon"

5. I added the following and it appears as follows which should look at inf first.:

%SystemRoot%\inf;

6. This fixed the installer issue! So we need to make sure that %SystemRoot%\inf is in the proper location in the registry for that file to build.

7. The other item being is that this infcache.1 in the Windows Directory can corrupt however, deleting it allows Windows to rebuild.

This has fixed all of my instances!

Occasional Contributor

Re: Junos Pulse - empty window (Win 7, 64-bit)

Also note, I got this by working with dev after working through the levels of tech support. Good people!

New Contributor

Re: Junos Pulse - empty window (Win 7, 64-bit)

Ther registry setting was correct on the computer that is seeing the issue. I renamed the infcache file and moved it to another directory and I still was unable to run the Pulse install. Actions are rolled back any time I have try to install from the standalone installer. Installing from the web installs but with no options available.

Thanks for posting your solution. I may have to take over the laptop and call Juniper.

Highlighted
Occasional Contributor

Re: Junos Pulse - empty window (Win 7, 64-bit)

Interesting... I've had 15 or 20 cases now and one combination or another has fixed the "rollback" issue every single time...

New Contributor

Re: Junos Pulse - empty window (Win 7, 64-bit)


@aclaypool wrote:

Ther registry setting was correct on the computer that is seeing the issue. I renamed the infcache file and moved it to another directory and I still was unable to run the Pulse install. Actions are rolled back any time I have try to install from the standalone installer. Installing from the web installs but with no options available.



I'm also running into this issue with all my Win7 machines. After quite the long tech support call today, we found our Sophos ESAV is causing an installation conflict. The problem is that one product will not install correctly if the other is already installed, so it's currently either Sophos or Pulse, not both in the current configuration. I'm waiting to hear something back tomorrow.

Occasional Contributor

Re: Junos Pulse - empty window (Win 7, 64-bit)

JTAC worked with another customer experiencing this same issue where Sophos Firewall client could not be installed in conjunction with JUNOS Pulse.

Issue was occurring on Windows 7 32-bit with Sophos 10 and JUNOS Pulse 2.x.

The symptoms of incomplete installation of JUNOS Pulse can show up in the Pulse client having no connections listed when it is launched. Pulse will appear to have been installed successfully but it's only the Pulse client UI that is getting successfully installed and the necessary services to run Pulse are missing.

In C:\Windows\Temp\Sophos client firewall driverhelper log.txt we found an exception error when trying to install scfndis which reported

NDISDriverInstaller::InstallDriver: Failed to instal SOPHOS_scfndis

JUNOS Pulse also has several services that bind to NDIS drivers so it made sense that the problem could be related to the conflict between the two apps.

Upon doing a search for this error on the Sophos Community Board we found an article that provided the cause and resolution for this issue.

The article is at http://www.sophos.com/support/knowledgebase/article/113328.html and we were able to resolve the problem with the second resolution mentioned at the end of the article:

increase the maximum number of network filter drivers allowed on the computer by editing the Windows registry. This option could be considered on virtual machines which may have many extra network filter drivers installed by the virtualization software. The registry key to edit is: HKLM/SYSTEM/CurrentControlSet/Cotnrol/Network/MaxNumFilters.

We increased the NetworkMaxNumFilters from 8 to 16 and this resolved the issue. Sophos FW successfully installed with JUNOS Pulse.

Hope this helps.

New Contributor

Re: Junos Pulse - empty window (Win 7, 64-bit)


@kmaybe wrote:

We increased the NetworkMaxNumFilters from 8 to 16 and this resolved the issue. Sophos FW successfully installed with JUNOS Pulse.


I found after-the-fact the max setting on this registry key is actually 14.

JB

Occasional Contributor

Re: Junos Pulse - empty window (Win 7, 64-bit)

Just wanted to confirm what jbaustert already posted that the max number of drivers for the reg key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\MaxNumFilters is 14.

Not applicable

Re: Junos Pulse - empty window (Win 7, 64-bit)

Changing the registry-key of MaxNumFilters worked for me.

 

I had the same issue with Windows7 64bit and AVG virus scanner.

 

Kind regards,

 

Maarten Vervoorn