cancel
Showing results for 
Search instead for 
Did you mean: 

Junos Pulse - empty window (Win 7, 64-bit)

Respected Contributor

Re: Junos Pulse - empty window (Win 7, 64-bit)

The adjustment to MaxNumFilters can happen regardless of AV; other VPN clients can cause this or VM products as well. Just something to keep in mind when planning deployment
Occasional Contributor

Re: Junos Pulse - empty window (Win 7, 64-bit)

Old post, but the reg hack still helped me with 5.x of Pulse.

I love it when people actually post helpful real world experience.

 

Thanks guys.

Especially - kmaybe and rhornberger!

Highlighted
Occasional Contributor

Re: Junos Pulse - empty window (Win 7, 64-bit)

JTAC just informed me they have a KB out for this problem....

 

Juniper KB on the subject:

http://kb.pulsesecure.net/InfoCenter/index?page=content&id=KB26656

 

Link to TechNet from Juniper KB:

http://blogs.technet.com/b/joscon/archive/2011/02/21/windows-7-service-pack-1-fails-with-error-code-...

Occasional Contributor

Re: Junos Pulse - empty window (Win 7, 64-bit)


@MichAda wrote:

JTAC just informed me they have a KB out for this problem....

 

Juniper KB on the subject:

http://kb.pulsesecure.net/InfoCenter/index?page=content&id=KB26656

 

Link to TechNet from Juniper KB:

http://blogs.technet.com/b/joscon/archive/2011/02/21/windows-7-service-pack-1-fails-with-error-code-...


I like that they say it's not possible to query the key and find out if there's enough space in their KB. When on my side I believe I could build a script that would be able to do it.

 

Not impressed by Juniper on their support for Junos Pulse lately.

Respected Contributor

Re: Junos Pulse - empty window (Win 7, 64-bit)

I am sorry to hear that you have not had a good experience with the Junos Pulse support team recently. And that this particular subject is one that we are not equipped to resolve. If you have not done so already, it may be a good idea to put a request in with your account team to have the ability to identify this scenario to provide an error to the user other than ?failed? or, as your experience is showing, the blank window upon installation (which should not be related to the inability to complete driver installation).
New Contributor

Re: Junos Pulse - empty window (Win 7, 64-bit)

<quote>increase the maximum number of network filter drivers allowed on the computer by editing the Windows registry. This option could be considered on virtual machines which may have many extra network filter drivers installed by the virtualization software. The registry key to edit is: HKLM/SYSTEM/CurrentControlSet/Cotnrol/Network/MaxNumFilters.</quote>

 

I was having the same problem after installing VirtualBox. This resolved the problem. Thanks!

Not applicable

Re: Junos Pulse - empty window (Win 7, 64-bit)

Well, I had the same issue on a Windows 7 32-bit system. I shall post my experience just in case someone runs into this -

 

1. Firstly, I had a freshly reimaged system to start with. I had installed 2 USB 3G modems and their dialers and drivers on my system. I am stating this because this there is a mention of MaxNumFilters on this thread.

 

2. I went to my client company's site where I had to authenticate myself and download the Junos Pulse set-up. The set-up is not through an offline installer but it is all-web (obviously, the installer will actually be downloaded in the background and placed in some temporary folder).

 

3. I did quite a few Next clicks and the set-up was on the last stages when I experienced a BSOD (Windows blue screen).

 

4. As I restarted the system, I firstly got a Windows driver error about a couple of drivers not properly installed. I went back to my client company's site to download the Junos Pulse set-up.

 

5. It went through and I ended up with a grey Pulse icon in the system tray saying 'Pulse:'. Rightclicking it did show our client's two connections but clicking on 'Connect ' would do nothing. Launching the Pulse UI showed no connections and no options to add one either.

 

6. Researching on Juniper's forums suggested by symptoms were caused either by the MaxNumFilters registry key (KB22191) or a corrupt INFCACHE.1 file (KB26656) on Windows. None were applicable in my case -

KB22191 - Observing issues with installing Junos Pulse or connecting to resources over the VPN tunnel.

KB26656 - Junos Pulse installation fails on Windows PCs due to the maximum number of installed filter drivers

 

7. I then tried a host of options involving uninstalling and reinstalling the Junos Pulse set-up (at least 14 times), even using Revo Uninstaller to do a cleaner uninstall, using a new Windows user account, uninstalling one of my USB 3G modem dialers and drivers, trying the latest as well as an outdated version of JRE, trying a different browser (Firefox) - all followed by a Windows restart. Nothing worked. Nothing at all.

 

8. I finally found a System restore point that was created by another software install just before I started with the Junos Pulse set-up. Reverting to that FIXED it. I suspect that the blue screen crash messed up the drivers real bad; so much so that an uninstall and reinstall could not help.

 

I hope this helps someone.

New Member

Re: Junos Pulse - empty window (Win 7, 64-bit)

Hi, this happened to me & this solved the problem. 

 

Under my computer search bar, i typed "pulse secure" and several options pop up. I then chose "Repair Pulse Secure" under Apps and follwed the steps. After repair, my Pulse secure is up and running again! 

 

Hope this will help anyone! Smiley Happy