cancel
Showing results for 
Search instead for 
Did you mean: 

Junos Pulse ignores settings on SA

Highlighted
Occasional Contributor

Junos Pulse ignores settings on SA

I've set on SA 2500 7.4R4 in role > vpn tunneling > options not to Launch client during Windows Interactive User Logon.

Junos Pulse still starts when Windows start.

On Junos Pulse > Connections I've set not to show splash screen, but I still see it when Junos Pulse starts.

On setting Connection is established I have "Automatically after user sings in to the desktop". But the behavior is "Automatically when the machine starts. Connection is authenticated again when the user sings in to the desktop."

 

I try uninstall Junops Pulse and connect thrugh web with different account, different role, different Connection set but with no succes.

 

What I am doing wrong?

 

Jakub Falt_nek

 

10 REPLIES 10
Highlighted
Regular Contributor

Re: Junos Pulse ignores settings on SA

Type comparing the connstore.dat file to the exported configuration file (.jpnpreconfig file).

For the settings to update both the following must be true:

1. Server-id: must be identical

2. The  version in connstore.dat must be less than the server side version (shown in the exported file)

Highlighted
Respected Contributor

Re: Junos Pulse ignores settings on SA

Yes, that is correct: Pulse will always launch when the user logs in. The difference is you will not see it if you disable the splash page & a connection will not be established if users are required to launch manually.

Yes, the Windows integrated launch option on the role is Network Connect specific. To achieve credential provider-based login with Pulse, you define those options on the connection set.
Highlighted
Contributor

Re: Junos Pulse ignores settings on SA

connstore.dat is updated every time I connect but part "machine settings" never changes.

For example even if I connect to role which has in Connection settings splash screen disabled, in connstore.dat it is still enabled.

Highlighted
Contributor

Re: Junos Pulse ignores settings on SA

Thanks for the help. I am now able to disable splash screen but options in Connection is established:still working in a strange way.  Manually by the user and Automatically after users signs in to the desktop works but even I have set this options I think Junos Pulse starts after machine starts because I see Junos Pulse icons on logon screen (see screenshot in attachement). Is this correct?

And setting in role settings > vpn tunneling > options  works only for Network Connect?

Highlighted
Respected Contributor

Re: Junos Pulse ignores settings on SA

The GINA/credential provider setting on the role is only for legacy network connect.
Do you have multiple connection sets defined for each connection type? Is the right connection profile assigned to your role? Have you done testing with multiple options? Are you using machine auth or user certificates?
Highlighted
Super Contributor

Re: Junos Pulse ignores settings on SA

Hi,

 

under setting " connection is established" ,set it to Manually by the user..

 

Regards,

Jay

Highlighted
Occasional Contributor

Re: Junos Pulse ignores settings on SA

What is GINA/credential provider setting?

 

I have only one connection set for connection type.

Yes, I tested different options but nothing changed.

We don't use any certificates.

Highlighted
Occasional Contributor

Re: Junos Pulse ignores settings on SA

But I want to connect automatically after user signs in to the desktop, but I don't want  Junos Pulse to connect before it.

 

Ideally I want to be able to set two scenarios.

 

1. Disable Junos Pulse to start after user signs in to the desktop. And then when user open Junos Pulse, to connect automatically.

 

2. Enable Junos Pulse to start when user signs in to the desktop (or even better allow user to choose during Junos Pulse installation) and connect automatically.

Highlighted
Regular Contributor

Re: Junos Pulse ignores settings on SA

It could be the local configuration file C:\Program Files\Common Files\Juniper Networks\connstore.dat is not getting updated because Pulse is not recognizing it as an older version of the appliance configuration.

Check out this thread for some hints on what to check https://forums.pulsesecure.net/topic/pulse-connect-secure/196417-pulse-connection-configuration-file...