cancel
Showing results for 
Search instead for 
Did you mean: 

MAC OS 10.8.2 Pulse Client Does Not Work (Connects successfully, but then no network connectivity on VPN or Internet)

GaryS_
New Contributor

MAC OS 10.8.2 Pulse Client Does Not Work (Connects successfully, but then no network connectivity on VPN or Internet)

Hello,

 

I have a couple of Macbooks where Junos Pulse does not work. There are no other VPN clients installed on them. The VPN works successfully on all our windows clients, and some of our Macbooks. All the MACs are the same specs and OS.

 

I have tried pulse clients 3 and 4 with the same problem. I'm connecting to a MAG2600 (SSLVPN) connected to a SRX240.

 

What Happens

 

  • The Pulse Client installs successfully on the Macbook
  • It connects successfully
  • However I loose all internet connectivity (eg I cannot ping google.com not what the Pulse client is active).
  • I cannot ping any internal servers on our VPN.
  • When I ping anything, I get the error below in terminal. (10.30.17.6 is a server on the internal network).
  • As soon as I disconnect the pulse client, I regain internet connectivity.

Any assistance would be greatly appreciated. As it stands, I cannot vouch for the reliability of Junos VPN's on MACs.

 

Ping Output (when pulse connected.)

 

mac:~ lyndoch$ ping 10.30.17.6
PING 10.30.17.6 (10.30.17.6): 56 data bytes
ping: sendto: Device not configured
ping: sendto: Device not configured
Request timeout for icmp_seq 0
ping: sendto: Device not configured
Request timeout for icmp_seq 1
ping: sendto: Device not configured
Request timeout for icmp_seq 2

13 REPLIES 13
Kita_
Valued Contributor

Re: MAC OS 10.8.2 Pulse Client Does Not Work (Connects successfully, but then no network connectivity on VPN or Internet)

Hello Gary,

 

You'll want to check the Advanced Details within Pulse to see if Bytes are being received through the tunnel.  There may be issues with the creating the tunnel which JTAC will need to review debug logs.  If you go into File > Logs > Save As.  This should give all the necessary files JTAC needs to review to confirm if there is an issue on the Pulse client side.

GaryS_
New Contributor

Re: MAC OS 10.8.2 Pulse Client Does Not Work (Connects successfully, but then no network connectivity on VPN or Internet)

Hello,

 

Please find logs attached. 

 

Here is a bit more info. We've just purchased a new MacBook Air. It has the same problem. The Log Files are from that laptop.

 

Prior to moving to Juniper, we has a Cisco VPN. All MACs worked successfully with that VPN.

 

Regards,

Gary.

ohwell_
Not applicable

Re: MAC OS 10.8.2 Pulse Client Does Not Work (Connects successfully, but then no network connectivity on VPN or Internet)

I'm seeing the same problem.

 

Do you have Back to My Mac enabled? It typically uses network interface utun0 and so does Junos Pulse. Pulse seems to be partly hardcoded to require utun0. So, it doesn't work if it gets utun1.

 

Oliver_07_
Not applicable

Re: MAC OS 10.8.2 Pulse Client Does Not Work (Connects successfully, but then no network connectivity on VPN or Internet)

I have got the same problem.

 

Is there a solution right now ?

zanyterp_
Respected Contributor

Re: MAC OS 10.8.2 Pulse Client Does Not Work (Connects successfully, but then no network connectivity on VPN or Internet)

Unfortunately, I can't make this happen. I'm using 10.8.4 and it works without issue to multiple IVEs from multiple machines (all with back to my Mac enabled).
rezadast2_
Not applicable

Re: MAC OS 10.8.2 Pulse Client Does Not Work (Connects successfully, but then no network connectivity on VPN or Internet)

Disabling Back to My Mac solved my issue. Pulse was getting utun1 and after I disabled Back to My Mac, the pulse client got utun0. Worked like a charm. Thanks!

Kita_
Valued Contributor

Re: MAC OS 10.8.2 Pulse Client Does Not Work (Connects successfully, but then no network connectivity on VPN or Internet)

Thank you for the feedback.  We are working on a solution for the back to my mac issue.

zanyterp_
Respected Contributor

Re: MAC OS 10.8.2 Pulse Client Does Not Work (Connects successfully, but then no network connectivity on VPN or Internet)

What is your split tunneling policy? If it's disabled, can you confirm when you enable it that the issue resolves itself (with back to my Mac enabled)?
marine110303_
Occasional Contributor

Re: MAC OS 10.8.2 Pulse Client Does Not Work (Connects successfully, but then no network connectivity on VPN or Internet)

Running into the same error but the user does not have "back to my MAC running". I have 2 VPN environments running right now (in the middle of a migration). 1 has split-tunneling and the other does not. On  the split-tunneling environment all traffic even traffic that should go to the tunnel goes out the users internet connection. In the environment without split-tunneling the user has no network/internet connectivity.. The byte counter is incrementing on the client and the route table is showing utun0

 

User is on Java 7 and Junos Pulse 5.0

OSX 10.9 Mavericks

 

Any movement towards a solution for this?

 

Thanks