cancel
Showing results for 
Search instead for 
Did you mean: 

Net LocalGroup command hanging when Pulse VPN connected

Highlighted
Visitor

Net LocalGroup command hanging when Pulse VPN connected

Hi all, first poster here!

 

We have a very odd problem with a limited number of users and we can't figure out why these users in particular are having the problem.

 

When not connected to with Secure Connect, if either of the users run a simple:

 

NET LocalGroup Administrators

Command, it returns the result immediately. 

 

However after we connect using Connect Secure, and these two users re-run this same command, we have up to a 2 minute wait for the command to complete. Other applications on the system that need to query the local admin  group are also hanging (it's easier to test  just running the NET command).

 

As mentioned the problem only occurs on a few systems. 

 

On ALL systems, we notice that on connection to VPN, there is a brief hang when running the NET command - during the connection setup - but once the connection is complete, it runs fine. So something is going on that causes the NET command to hang each time, it's just on two systems it's perminant (when on VPN).

 

So the question is - why does starting the VPN cause issues with running this specific NET command?

 

Does the 'host checker' / VPN setup app lock access to local user group membership?

 

Jeff

1 REPLY 1
Highlighted
Moderator

Re: Net LocalGroup command hanging when Pulse VPN connected

@accjeff That's weird. So the NET command would trigger/rely on any response which gets transmitted over the network i.e. through tunnel or is it purely local?

PCS Expert
Pulse Connect Secure Certified Expert