cancel
Showing results for 
Search instead for 
Did you mean: 

OpenFileMapping(Neoteris:Setup:MMF:Juniper Network Connect 7.1.0) failed: 2.

Mike.S_
New Contributor

OpenFileMapping(Neoteris:Setup:MMF:Juniper Network Connect 7.1.0) failed: 2.

On a Win7 PC, which had been successfully connecting to multiple sites using Network Connect, recently no connections work. When attempting to connect, after the "launching application..." nothing more happens. The logs show these messages repetitively:

 

00188,09 2012/09/30 10:24:23.130 3 myname dsNetworkConnect.exe dsNetworkConnect p2832 t1BEC dsUserLoginDlg.cpp:306 - 'NCUI' URL: https://myportal.example.com/dana/nc/ncrun.cgi?launch_nc=1 00212,09 2012/09/30 10:24:23.130 3 myname dsNetworkConnect.exe dsNetworkConnect p2832 t1BEC NeoterisSetupPublic.c:57 - 'DSSetupInitializeParam()' Open memory mapped file: NeoterisSmiley Frustratedetup:MMF:Juniper Network Connect 7.1.0 00215,09 2012/09/30 10:24:23.131 1 myname dsNetworkConnect.exe dsNetworkConnect p2832 t1BEC NeoterisSetupPublic.c:60 - 'DSSetupInitializeParam()' OpenFileMapping(NeoterisSmiley Frustratedetup:MMF:Juniper Network Connect 7.1.0) failed: 2. 00188,09 2012/09/30 10:24:23.616 3 myname dsNetworkConnect.exe dsNetworkConnect p2832 t1BEC dsUserLoginDlg.cpp:306 - 'NCUI' URL: https://myportal.example.com/dana/nc/ncrun.cgi?launch_nc=1 00212,09 2012/09/30 10:24:23.616 3 myname dsNetworkConnect.exe dsNetworkConnect p2832 t1BEC NeoterisSetupPublic.c:57 - 'DSSetupInitializeParam()' Open memory mapped file: NeoterisSmiley Frustratedetup:MMF:Juniper Network Connect 7.1.0 00215,09 2012/09/30 10:24:23.616 1 myname dsNetworkConnect.exe dsNetworkConnect p2832 t1BEC NeoterisSetupPublic.c:60 - 'DSSetupInitializeParam()' OpenFileMapping(NeoterisSmiley Frustratedetup:MMF:Juniper Network Connect 7.1.0) failed: 2. 00188,09 2012/09/30 10:24:24.285 3 myname dsNetworkConnect.exe dsNetworkConnect p2832 t1BEC dsUserLoginDlg.cpp:306 - 'NCUI' URL: https://myportal.example.com/dana/nc/ncrun.cgi?launch_nc=1 00212,09 2012/09/30 10:24:24.286 3 myname dsNetworkConnect.exe dsNetworkConnect p2832 t1BEC NeoterisSetupPublic.c:57 - 'DSSetupInitializeParam()' Open memory mapped file: NeoterisSmiley Frustratedetup:MMF:Juniper Network Connect 7.1.0 00215,09 2012/09/30 10:24:24.286 1 myname dsNetworkConnect.exe dsNetworkConnect p2832 t1BEC NeoterisSetupPublic.c:60 - 'DSSetupInitializeParam()' OpenFileMapping(NeoterisSmiley Frustratedetup:MMF:Juniper Network Connect 7.1.0) failed: 2.

"ipconfig /all" shows the NC does not connect:

Ethernet adapter Local Area Connection*:     Media State . . . . . . . . . . . : Media disconnected    Connection-specific DNS Suffix  . :    Description . . . . . . . . . . . : Juniper Network Connect Virtual Adapter    Physical Address. . . . . . . . . : 00-FF-70-45-1E-08    DHCP Enabled. . . . . . . . . . . : Yes    Autoconfiguration Enabled . . . . : Yes

 

Logging into the same PC as a different user, and things work fine, which makes me think it might be a registry problem. I've tried removing all NC components (they get automatically re-installed when going through the portal), with no change in behaviour. Windows firewall is off.

2 REPLIES 2
zanyterp_
Respected Contributor

Re: OpenFileMapping(Neoteris:Setup:MMF:Juniper Network Connect 7.1.0) failed: 2.

Generally those are fine; it should not be an error point. What error message do you see as a user?
Mike.S_
New Contributor

Re: OpenFileMapping(Neoteris:Setup:MMF:Juniper Network Connect 7.1.0) failed: 2.

There is no user error message. It just silently hangs, with nothing happening. I can see that no connection has been created, by doing "ipconfig /all" and "route print," which show no connection and no VPN routes, respectively.

 

Back when it worked, I'd open NC, enter name/pass, I'd get a post-signin notification (click Proceed), then it would say "Please Wait," a "Launching Application" notification would pop up briefly, then all windows would close and I'd be connected. Now, all of that happens, except the "Please wait" window never closes and I don't get connected. It will sit there forever like that. With "NC Troubleshooting" running, it just continually scrolls the messages I documented in my first post.

 

The connection is apparently partiatially formed, if I shut everything down and try again, it will come up with the "there are existing connections" dialog.

 

It's not the server side - I can connect with another client, or can connect if I change to a different user on the same PC. The same thing occurs with two different servers (although they're running slightly different versions, so the client gets reinstalled anytime I switch between them).