Showing results for 
Search instead for 
Did you mean: 

Passing credentials to OWA

Frequent Contributor

Passing credentials to OWA

Not sure what I'm missing, I've done this with a couple of applications but passing the log-in credentials to OWA continues to elude me. Has anyone done this successfully? If so, I'd certainly appreciate it if you can point me in the right direction.


Occasional Contributor

Re: Passing credentials to OWA

What version are you on. I tried all options on 5.5 but couldn't get OWA to accept credentials until I upgraded to 6.0. Are you having the IVE prompt you for credentials and then not allow access? Are you getting an error message that the page cannot be displayed? Or does it continually try to connect never returning a message?


Super Contributor

Re: Passing credentials to OWA

On 6.0, I have made it work using the IVE logon ID and password by specifying a web SSO policy for Basic Auth with the resource https://my.mail.server:443/exchange/* (where my.mail.server is the name of my OWA server) with action "Use system credentials". This works for me. As you can see from the URL, we use HTTPS to access OWA. I'm guessing the URL would be http://my.mail.server:80/exchange/* if your business used HTTP for OWA.
Occasional Contributor

Re: Passing credentials to OWA

We have been using this since firmware 5.0 (and currently firmware 6.1R2) and it works with OWA 2003.

This SSO setup is based on using HTTPS (443), if you use HTTP (80) just modify the entries.
We use LDAP-S to Active Directory, but it should work for normal AD authention.

OWA.YOURCOMPANY.COM = the URL for your OWA server

Create (or edit) your RESOURCE PROFILES > WEB
Scroll down and enable AUTOPOLICY: SINGLE SIGN-ON.



In the box just below these settings, make these parameters:

LABEL = destination, NAME= destination, Value =, Not modifiable
LABEL = SubmitCreds, NAME= SubmitCreds, Value = Logon+On, Not modifiable
LABEL = Username, NAME= username, Value = <USERNAME>, Not modifiable
LABLE = Password, NAME= password, Value = <PASSWORD>, Not modifiable


New Contributor

Re: Passing credentials to OWA


What I'am doing is the opposite of making a form post SSO; I change the OWA setup from form-post to standard authentication methods with integrated authentication or basic authentication (but please use SSL to your OWA server as well).

If you do it this way, you have a very easy hassle free SSO for your OWA solution, if it's OWA2000, OWA2003 or even OWA2007.


Follow the steps below (OWA 2003):

Configuring the Exchange Server for standard-based authentication


To enable standard -based authentication:

1. On the Exchange server, log on with the Exchange administrator account, and then start

Exchange System Manager.

2. In the console tree, expand Servers.

3. Expand the server for which you want to enable forms-based authentication, and then

expand Protocols.

4. Expand HTTP, right-click Exchange Virtual Server, and then click Properties.

5. In the Exchange Virtual Server Properties dialog box, on the Settings tab, in the Outlook

Web Access pane, select the Enable standard Based Authentication option.

6. Click Apply, and then click OK.

After you change the OWA from form-based to standard based authentication; you can set a SSO based on NTLM-auth on the IVE with the logon credentail variables (<USER> and <PASSWORD>)

Good luck,


Occasional Contributor

Re: Passing credentials to OWA

joepope: is this solution working with Internet Explorer and Firefox?

I'm asking, because I've tried it this way and it works in IE like a charm. In Firefox I get cought in a redirection loop, though...

Unfortunately switching to basic auth on the exchange server is not an option. Any Idea how i can get this resolved? (6.1R4 (build 13437)

Message Edited by Markus_Z on 09-02-2008 03:37 AM
Not applicable

Re: Passing credentials to OWA

Thanks, joepope. It really works with your label parameters on my OWA 2007. I just need to change the destination to /owa/

It saves a lot of time researching.