cancel
Showing results for 
Search instead for 
Did you mean: 

Please install correct JRE version - correct version installed

tomas013
New Contributor

Re: Please install correct JRE version - correct version installed

Hello,

 

I have the same problem as @manisci . I have apple m1 max and I have to use JSAM.

 

Do I have to create a support ticket as well?

Thanks.

 
r@yElr3y
Moderator

Re: Please install correct JRE version - correct version installed

@tomas013 Yes, please. Thank you!

PCS Expert
Pulse Connect Secure Certified Expert
prakhar.es
Occasional Visitor

Re: Please install correct JRE version - correct version installed

help me on this

rbnjms
New Contributor

Re: Please install correct JRE version - correct version installed

Follow the steps in the post on 30/09/2021. If you have the same problem as me, the JRE installed on your Mac is missing a library, called libjli.dylib. I am using Java 8 Update 311. The solution installs a JDK in addition to the existing JRE and adds a symbolic link (the "ln -s" command) from the JDK library to the JRE location. I downloaded and installed the JDK from Microsoft so I followed the instructions in bold for Open JDK. First you download and install the macos asset from the Open JDK link. Then you open a Terminal on your Mac and copy and execute the two commands underneath the Open JDK link. The two commands start with "sudo".

 

As it happens a colleague in work followed these instructions successfully today, although he used a different JDK.

omerfamd
New Contributor

Re: Please install correct JRE version - correct version installed

i can't found that (30/09/2021) message ?


@rbnjms wrote:

Follow the steps in the post on 30/09/2021. If you have the same problem as me, the JRE installed on your Mac is missing a library, called libjli.dylib. I am using Java 8 Update 311. The solution installs a JDK in addition to the existing JRE and adds a symbolic link (the "ln -s" command) from the JDK library to the JRE location. I downloaded and installed the JDK from Microsoft so I followed the instructions in bold for Open JDK. First you download and install the macos asset from the Open JDK link. Then you open a Terminal on your Mac and copy and execute the two commands underneath the Open JDK link. The two commands start with "sudo".

 

As it happens a colleague in work followed these instructions successfully today, although he used a different JDK.


 

omerfamd
New Contributor

Re: Please install correct JRE version - correct version installed

I Can't found your message ? 


@rbnjms wrote:

Follow the steps in the post on 30/09/2021. If you have the same problem as me, the JRE installed on your Mac is missing a library, called libjli.dylib. I am using Java 8 Update 311. The solution installs a JDK in addition to the existing JRE and adds a symbolic link (the "ln -s" command) from the JDK library to the JRE location. I downloaded and installed the JDK from Microsoft so I followed the instructions in bold for Open JDK. First you download and install the macos asset from the Open JDK link. Then you open a Terminal on your Mac and copy and execute the two commands underneath the Open JDK link. The two commands start with "sudo".

 

As it happens a colleague in work followed these instructions successfully today, although he used a different JDK.


 

omerfamd
New Contributor

Re: Please install correct JRE version - correct version installed

i Can't found your message