cancel
Showing results for 
Search instead for 
Did you mean: 

Pulse Secure and Ubuntu 18.10. Kernel > 4.18

New Contributor

Pulse Secure and Ubuntu 18.10. Kernel > 4.18

Hi everyone.

 

I've updated my computer from ubuntu 18.04 to ubuntu 18.10 and now i'm not able to connect to my vpn.

 

I'm using the Pulse Secure Client 9.0R1(739) 64 bits and the error showed in the log is:

20181019132634.591969 pulsesvc[p18931.t18931] pulseui.error Failed to read return cookie from host checker process (pulseUi.cpp:1003)
20181019132634.592046 pulsesvc[p18931.t18931] pulseui.error initiatePreAuthHostCheck() failed, isPostAuth: 1 (pulseUi.cpp:1110)

 

When trying to connect it can't do the host check.

 

Loading Components...
Please wait. This may take several minutes.
Host Checker
  
If an error prevents a component from loading properly, you can click here to continue. Not all functionality may be available.
 

Thanks everyone for the help and best regards.

11 REPLIES
New Contributor

Re: Pulse Secure and Ubuntu 18.10

I think this is the same problem I have when using the latest kernels 4.18.x (on Ubuntu 16.04), earlier kernels work for me.

Contributor

Re: Pulse Secure and Ubuntu 18.10

Hi bernalvarela,

 

Looks like the authentication scheme is Host Checker + SAML. If so, then it is not supported as per the release notes

New Contributor

Re: Pulse Secure and Ubuntu 18.10

Yes, indeed the problem comes with the new kernel version, the 4.18.

 

I've tried with the old version, 4.15, and pulse secure works fine...

 

Contributor

Re: Pulse Secure and Ubuntu 18.10

Hi bernalvarela,

 

Thanks for mentioning this. An issue has been raised

New Contributor

Re: Pulse Secure and Ubuntu 18.10

Do you have an estimated date of a release being compatible with the kernel 4.18?.

 

Best regards.

Contributor

Re: Pulse Secure and Ubuntu 18.10

Sorry for the delay. The issue is being analyzed now. Will update once we proceed further

New Contributor

Re: Pulse Secure and Ubuntu 18.10

BTW, the same problem applies for 4.19.x

Highlighted
Zod
Pulser

Re: Pulse Secure and Ubuntu 18.10. Kernel > 4.18

Currently, Pulse Secure Desktop client does not support Ubuntu 18.10. We have provided the following KB for further tracking on support for Ubuntu 18.10

 

KB43943 - Support for Ubuntu 18.10 with Pulse Secure Desktop client (Linux)

Community Manager

Re: Pulse Secure and Ubuntu 18.10

Hello All,

 

Pulse Secure is aware of the problem state we are actively discussion potential solutions for the issue.  If there are possible known workaround, we will share this as soon as possible.