cancel
Showing results for 
Search instead for 
Did you mean: 

Pulse client issue with Adaptive Auth.

Frequent Contributor

Re: Pulse client issue with Adaptive Auth.

No solution yet. May be getting closer though.

 

Looking at this with our SE, he pointed out something interesting during our testing. When using desktop version of Pulse (be it Windows or MAC)  with adaptive auth configured in the realm, the user access log shows the "agent"  field was blank ... "agent =     "   However, once you you remove the adaptive auth component from the realm and just go with AD, the agent field is populated.

 

This would suggest that with adaptive auth configured, IVE is unable to determine user agent.  Therefore, it doesnt know which defender file to invoke, essentially intead of using the customized defender files uploaded as part of the template, it is presenting a generic passcode prompt. At least that's what it looks like

 

So far, I have observed this on all versions of IVE code ranging from 7.1Rx all all the way up to 7.4R3

 

Again, the part which completely throws me off here is that mobile versions of Pulse work just fine.

Highlighted
Occasional Contributor

Re: Pulse client issue with Adaptive Auth.

Has anyone gotten this to work or come up with a work around so users just have to do a single click instead of launching a browser before handing off to Pulse or NC?

G

Highlighted
New Contributor

Re: Pulse client issue with Adaptive Auth.

@red - we're in the process of trying RSA Adaptive Authentication (AA) also and am interested to know what changes you made to the original defender.thtml, defender mobile and defender-ipad files. So far RSA was kind enough to provide us with a modified defender file and AA is redirecting fine when accessed from a desktop PC. The problem we are running into is with mobile devices. I am not sure what changes and RSA, unfortunately, is not very helpful. So I would appreciate it if you or anyone can shed some light. I would like to get it to work through Pulse also, but it would be great to just get it working on a mobile device. Thanks.

Highlighted
New Contributor

Re: Pulse client issue with Adaptive Auth.

@red - That worked for the mobile version of Pulse. Thank you. I didn't see the defender-mobile file in the template so I assume you meant Defender-mobile-webkit. The desktop version fails as it was ""unable to communicate with the server". I am going to create a case and get this looked into through our SE.

I also wondered if AA worked from the mobile browser so I did try AA from various mobile browser such as the stock Android browser, Chrome, Safari, but they all seem to fail. I did find a workaround. It seems to work just fine if you use a mobile browser that allows you to select the user agent. Dolfin Browser, for example, allows you to choose a different user agent and it worked fine if use the Desktop agent. 

Highlighted
Not applicable

Re: Pulse client issue with Adaptive Auth.

Just an FYI.  I opened a support case about the same issue where I was told by JTAC my SE needed to submit an enhancement request. Enhancement Request ER-056515 has been opened.  If you would let your account team aware of this, the more attention it gets, the sooner it might get fixed.  Thanks