Showing results for 
Search instead for 
Did you mean: 

RDP session failures

Occasional Contributor

RDP session failures

I have started getting random rdp session connection failures for random users on a clusered SA-4500 in active passive. When a user tries to launch an RDP link, they get a session timeout error and are unable to connect. This happens all RDP links including citrix web links. The issue seems to be user related, not computer related. The users can try different computers and still get the same error. However other users who use the exact same role and have the exact same role mappings, are able to connect without issues. Also if you use Network Connect to get to the servers you are able to access them fine. Only happens with web links and it seems to be user specific. The issue is happening to me now as well, I am the admin of the SSL VPN. Friday I was having no issues, I knew of other people having the issue, when I came in today I am now unable to launch RDP sessions. Nothing was changed on the SA device and other users are able to launch the exact same RDP sessions without problems. Weve done all the basic trouble shooting of unistalling Juniper stuff, updating java stuff, rebooting. Even tried new computers. When I look at my firewall logs, I can see the servers sending TCP - Reset commands when I try to connect to them.

I am running 6.5R2 and I have looked through all the relase notes and known issues, this does not appear to be listed. I have a case open with Juniper, but has anyone else experienced this issue?

Vijesh Bhat_
Occasional Contributor

Re: RDP session failures

Your request seems to be going to the destination but teh return traffic is being reset. Make sure to allow the return traffic in firewall too even if your firewall is Stateful.