cancel
Showing results for 
Search instead for 
Did you mean: 

RDP using JSAM

Highlighted
Not applicable

RDP using JSAM

Hi,

if I try to set up a new RDP connection using the 127.0.x.x address displayed in JSAM, my windows remote desktop client doesn't connect to the intended server, but to my own PC.

Does anyone know this problem and a solution to this?

6 REPLIES 6
Highlighted
Contributor

Re: RDP using JSAM

A address of 127.0.x.x is a loopback address which does mean your PC. You should not use this address to connect but use the FQDN or shortname instead.

Highlighted
Occasional Contributor

Re: RDP using JSAM

"A address of 127.0.x.x is a loopback address which does mean your PC. You should not use this address to connect but use the FQDN or shortname instead."

Ummm, really? Really really?

When you use the FQDN, it resolves to 127.0.1.x, assuming JSAM has modified the local hosts file or you've entered the mappings in your external DNS. I'm not sure why you're telling the OP not to use those addresses directly.

Highlighted
Super Contributor

Re: RDP using JSAM

have you tried to see if your computer is able to resolve the address? like go to a dos prompt and ping the FQDN that you setup in the Servername field in JSAM setting? You know that you can not use an IP address in the server name field in JSAM bec the local host file can not map an IP to another IP address.

Highlighted
New Contributor

Re: RDP using JSAM

Hi,


I saw this old thread, but in case anyone lands here and is experiencing this problem, here is the solution:

 

Basically, the reason you're failing to connect is because Juniper client proxies through the local loopback adapter AND if the system you're connecting *from* has remote desktop (terminal server) running on port 3389, this overrides the Juniper setup and you end up connecting directly to your own machine!

 

To get around this, make sure you are not running anything locally on 3389, that is select "Don't allow connections to this computer" from Control Panel -> System -> Remote (Windows 7.... might need reboot?)

 

Once you've done this, make sure you do not have anything open on 3389. i.e, this should *fail* to connect:

 

telnet 127.0.0.1 3389

 

Then connect to Juniper and all should be good to go!

 

Highlighted
New Contributor

Re: RDP using JSAM

 

By the way, if you ever did want to run both Juniper and still be able to RDP to your own laptop, you can change the port that RDP listens on with this info (reg key change)  :

 

http://support.microsoft.com/kb/306759

 

Highlighted
Respected Contributor

Re: RDP using JSAM

Another solution is in the JSAM application definition, check the option to dynamically choose a new port if the existing port is used.

It does require users to check the port to connect against, but it does work as well (and does not require registry modifications).