cancel
Showing results for 
Search instead for 
Did you mean: 

Redirect to home URL works in IE but not in Firefox

Highlighted
Contributor

Redirect to home URL works in IE but not in Firefox

Hi all

 

In my test environment, login to a realm/role works fine with IE but not with Firefox.  The problem comes immediately after the user is authenticated, and the SA redirects it to its home page.  The SA issues a number of redirects that work with IE, and although they are the same, Firefox does not seem to pick up the second redirect, but gets stuck at "/dana/home/starter0.cgi?check=yes"  (see policy trace below).  If I then manually change the URL in the browser to "/dana/home/starter.cgi" the home page resolves (after the last redirect).

 

Has anyone else seen this behaviour?  Is there a workaround?

 

The SA is running 7.2R4, and Firefox is 20.0.1.

 

 

 

 

If I run a policy trace on the (successful) IE session, we see

 

info - [10.1.2.11] - user(realm)[role] - 2013/05/09 17:02:29 - Session created, redirecting user to start page.  Sign-in done.
info - [10.1.2.11] - user(realm)[role] - 2013/05/09 17:02:29 - Automatically redirected from page "login" to the next start page "/dana/home/starter0.cgi?check=yes" before starting the session.
info - [10.1.2.11] - user(realm)[role] - 2013/05/09 17:02:31 - Automatically redirected from page "starter0" to the next start page "/dana/home/starter.cgi" before starting the session.
info - [10.1.2.11] - user(realm)[role] - 2013/05/09 17:02:31 - Automatically redirected from page "starter0" to the next start page "/dana/home/starter.cgi" before starting the session.
info - [10.1.2.11] - user(realm)[role] - 2013/05/09 17:02:31 - Automatically redirected from page "starter" to the next start page "/dana/home/index.cgi" before starting the session.
 
With Firefox, instead, we see
 

info - [10.1.2.11] - user(realm)[role] - 2013/05/09 16:57:08 - Sign-in successful, creating session
info - [10.1.2.11] - user(realm)[role] - 2013/05/09 16:57:08 - Session created, redirecting user to start page.
Sign-in done.
info - [10.1.2.11] - user(realm)[role] - 2013/05/09 16:57:08 - Automatically redirected from page "login" to the
next start page "/dana/home/starter0.cgi?check=yes" before starting the session.
info - [10.1.2.11] - user(realm)[role] - 2013/05/09 16:57:08 - Automatically redirected from page "starter0" to
the next start page "/dana/home/starter.cgi" before starting the session.
info - [10.1.2.11] - user(realm)[role] - 2013/05/09 16:57:22 - Automatically redirected from page "starter" to the
next start page "/dana/home/index.cgi" before starting the session.

3 REPLIES 3
Highlighted
Super Contributor

Re: Redirect to home URL works in IE but not in Firefox

Hi,

 

Looks like the below bug fixed in 7.3r5

 

7. endpointintegrity-others - The SA home page will get stuck and does not load user home-page,
when Host Checker is launched through the Firefox browser 19.x. (865613)

 

Regards,

Jay

Highlighted
Contributor

Re: Redirect to home URL works in IE but not in Firefox

Hi JayLaiz

 

Thanks for the hint.  It looks likely, I agree.  Unfortunately my test environment is running on DTE, and therefore on the latest published code, so my customer will have to take it on trust that the problem will be fixed when I configure it on the production systems.

 

Many thanks

Highlighted
Super Contributor

Re: Redirect to home URL works in IE but not in Firefox

Yes, the PR description looks exactly like the issue you are describing.

 

Regards,

Jay