cancel
Showing results for 
Search instead for 
Did you mean: 

Route not properly added to NC client

SOLVED
Highlighted
New Contributor

Route not properly added to NC client

Hi,


We just purchased a new MAG-2600 box and I've successfully setup the user roles and profiles and everything is working fine except the Network Connect.

I've observed that, after the client successfully connected to network connect, the route is not properly added.

The network connect subnet : 192.168.253.64/26

Local server subnet: 172.16.1.64/26.

Route print result from my pc:


IPv4 Route Table
===========================================================================
Active Routes:
Network Destination Netmask Gateway Interface Metric
0.0.0.0 0.0.0.0 192.168.1.254 192.168.1.66 25
127.0.0.0 255.0.0.0 On-link 127.0.0.1 306
127.0.0.1 255.255.255.255 On-link 127.0.0.1 306
127.255.255.255 255.255.255.255 On-link 127.0.0.1 306

172.16.1.111 255.255.255.255 On-link 192.168.253.102 1
192.168.253.102 255.255.255.255 On-link 192.168.253.102 257
192.168.253.255 255.255.255.255 On-link 192.168.253.102 257
224.0.0.0 240.0.0.0 On-link 127.0.0.1 306
224.0.0.0 240.0.0.0 On-link 192.168.1.66 281
224.0.0.0 240.0.0.0 On-link 192.168.179.1 276
224.0.0.0 240.0.0.0 On-link 192.168.131.1 276
255.255.255.255 255.255.255.255 On-link 127.0.0.1 306
255.255.255.255 255.255.255.255 On-link 192.168.253.102 257
255.255.255.255 255.255.255.255 On-link 192.168.1.66 281
255.255.255.255 255.255.255.255 On-link 192.168.179.1 276
255.255.255.255 255.255.255.255 On-link 192.168.131.1 276
===========================================================================

Only the DNS server ip address was added to the route. Not the whole segment.

I can access the local server if I add the route manually via route print on my pc.

Please advise how can I have the route automatically added to the NC client?

Regards

2 REPLIES 2
Frequent Contributor

Re: Route not properly added to NC client

As the DNS server is added I guess that Auto-allow IP's in DNS/WINS settings (only for split-tunnel enabled mode)'' is enabled, do you have a Split Tunneling Policy defined for the Role (Users > Resource Policies > Network Connect > Split-Tunneling Policies)?

Another potential cause is that another application is preventing the route table changes but as the DNS entry is added I doubt that is the solution.

New Contributor

Re: Route not properly added to NC client

Hi,


Thanks for pointing out.

I managed to find the mistakes. Is the split tunneling policy.

Routes added correctly to the client now.

Regards