cancel
Showing results for 
Search instead for 
Did you mean: 

SA-4000 6.0R3.1 - Problem with WSAM and file sharing

SOLVED
Highlighted
Occasional Contributor

SA-4000 6.0R3.1 - Problem with WSAM and file sharing

Hi!

I have a laptop on which i'm logging on through my domain at my office AND at my home (cached profile).

I'm logging on my SA-4000 at my home fine, start WSAM (I have a role that let me access my file server), I search for the ip address of my file server and I find it. I double-click on it and it ask me for my credential (Windows 2003 domain from my office WHICH is the same credential that i'm logged on my laptop).

Then, I instantly have an error message:

"incorrect session login, the username you enter is identical to the username you used to open the session"

If I use another doamin\username, it works fine.

??!!?? Any helps ??!!??

I don't want two create two username for everyone using my file sharing option on my VPN-SSL SA-4000 !!

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Occasional Contributor

Re: SA-4000 6.0R3.1 - Problem with WSAM and file sharing

Yes, I had to make a VBscript (including the username) to map the drive. It worked.

View solution in original post

7 REPLIES 7
Highlighted
Frequent Contributor

Re: SA-4000 6.0R3.1 - Problem with WSAM and file sharing

How are you searching for the IP address?

Do you have NetBIOS enabled on the SAM role?

Highlighted
Occasional Contributor

Re: SA-4000 6.0R3.1 - Problem with WSAM and file sharing

I enter the ip, not the server name when searching.

If I enter the same username (as I use when log on my laptop) when trying to access my file server; it is not working.

if I enter another username (it is working.)

thx for your help.

Highlighted
Frequent Contributor

Re: SA-4000 6.0R3.1 - Problem with WSAM and file sharing

First, add the ip address of the fileserver to the Users>Usersrole>SAM>Allowed Servers.

Example: 10.0.0.2 and ports 139,445

Second, add it to the SAM policies in Users>Resource Policies>SAM>Access Control and apply it to the role.

Example: 10.0.0.2 :139:445

Highlighted
Occasional Contributor

Re: SA-4000 6.0R3.1 - Problem with WSAM and file sharing

Tried that.

Looks like it is not the access/policies not properly configured on the SA-4000 (because if I enter a different username from the one logged on my laptop, it is working). So my policy is working fine.

Windows do not accept me entering the same username/password.

Surely, I am not the only person trying to set up file server access through a SA-4000 and logging on under a domain (loccaly stored profile) from home??

thx for your help!!!!!!!!!! Smiley Happy

Highlighted
Regular Contributor

Re: SA-4000 6.0R3.1 - Problem with WSAM and file sharing

Try the net use command with the user name set to %USERNAME%:
net use X: \\server\share /user:%USERNAME% /persistent:no
Highlighted
Occasional Contributor

Re: SA-4000 6.0R3.1 - Problem with WSAM and file sharing

Yes, I had to make a VBscript (including the username) to map the drive. It worked.

View solution in original post

Highlighted
Frequent Contributor

Re: SA-4000 6.0R3.1 - Problem with WSAM and file sharing


@RichelieuLuc wrote:
Yes, I had to make a VBscript (including the username) to map the drive. It worked.

What did the script say?

Something like this?

Dim oNet
Set oNet = CreateObject("WScript.Network")

onet-MapNetworkDrive "X:", "\\" & servername & "\" & sharename, , DomainName\UserName, Password