cancel
Showing results for 
Search instead for 
Did you mean: 

SSH timeout when using WSAM.

rswinter_
Frequent Contributor

SSH timeout when using WSAM.

Hi,

I've got a user who uses SSH through the WSAM so he can use Putty (and another app) instead of the built-in SSH client. He's reporting that he gets disconnected about 60 seconds of idle time. He doesn't need to restart WSAM or re-logiin to the SA, he just has to restart the putty session.

I couldn't find any timeout settings in the WSAM, so I was curions if anyone can point me to where it should be looking? It doesn't happen when not going through the SA, so it's something to do with that interraction...

Thanks.

-S

2 REPLIES 2
ruc_
Regular Contributor

Re: SSH timeout when using WSAM.

You can try two things:

 

1. Under Admin UI >  Configuration > NCP > Idle Connection Timeout > make sure the value is around 120 (the default value) Please do not deviate from 120 unless you have been explicitly advised by JTAC. A very large value will cause in extensive resource utilization because of maintaining too many idle connections and a very small value will result in experiences like what you described above.

 

2. If above does not help then take a tcpdump on the internal interface of the SA and see who is closing the connection? Is it the SA or is it the backend or an intermediate device between SA/backend.

 

Hope it helps.

cbarcellos_
Regular Contributor

Re: SSH timeout when using WSAM.

Along with the IVE configurations given above, You can also try to extend the idle time out on the SSH client. It could be disconnecting because you do not have the keepalive setting enabled (this activity will keep the connection from timing out).

 

In Putty this is found under "Connection --> seconds between keepalives (0 to turn off)" set this to something around 45 seconds if you are being disconnected after 60 seconds. I've also seen this issue with certain firewall configurations too.

 

Hope this helps