cancel
Showing results for 
Search instead for 
Did you mean: 

Sofware versions

SOLVED
Highlighted
Occasional Contributor

Sofware versions

Hi. We have Juniper MAG2600, running as primary VPN applaince and SA700 as reserve. Recommended software version for MAG2600 is 8.0R6.0 and for SA700 - 7.4R13.0. For now we are running the same software version on both devices to be able to copy users.cfg from MAG2600 to SA700 in case of trouble. If i update both devices to the latest version, will be i still able to copy configs from one to another?

 

Regards,

Andrei.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Valued Contributor

Re: Sofware versions

This is possible.  You may import a configuration to another device as long as it is lower than the device your are importing to (7.4R1 to 8.0R1).  You cannot import a configuration which is higher than the device you are importing to (8.0R1 to 7.4R1).

View solution in original post

6 REPLIES 6
Highlighted
Valued Contributor

Re: Sofware versions

Yes.  As long as the software versions are the same, you will be able to import and export the configuration without any issues.

Highlighted
Occasional Contributor

Re: Sofware versions

But that's the point. After upgrade it will be 8.0R6.0 on MAG2600 and 7.4R13.0 on SA700. So there is no chance to export config and users in this situation?

Highlighted
Valued Contributor

Re: Sofware versions

This is possible.  You may import a configuration to another device as long as it is lower than the device your are importing to (7.4R1 to 8.0R1).  You cannot import a configuration which is higher than the device you are importing to (8.0R1 to 7.4R1).

View solution in original post

Highlighted
Occasional Contributor

Re: Sofware versions

Oh, thanks a lot! That's what i need. MAG2600 with higher version is our primary device, so it will be ok.

Highlighted
Occasional Contributor

Re: Sofware versions

Decided not to create new topic and ask here. Today i tried to cope suers.cfg from our MAG2600 (which is running 8.0R8.1) to SA700 (7.4R13.2). And i've got the following error:

error.png

So it means that it's impossbile to copy users and system cfg from appliznce to aplliance if they are running different versions?

Highlighted
Contributor

Re: Sofware versions

Kitna answered your question.  If the config file version is from a lower version than your current MAG version it will work.  If the config version is a higher version than what is running on your MAG appliance, then you cannot import it.

 

The appliances also have the ability to rollback to the previous version, so you can use that as an option.  Just keep in mind if you roll back to the previous versions, you will lose any changes you have made after the upgrade.