cancel
Showing results for 
Search instead for 
Did you mean: 

Terminal Service Client - Permission Denied

SOLVED
Highlighted
Contributor

Terminal Service Client - Permission Denied

I set up a couple of users and they can login jsut fine to VPN and get to their sessions. No when they click on a session they get a error "attached"

We verified that remote desktop is on and it works, we can remote to it internally. The user is trying to login with a XP Laptop and going to a XP desktop. In the Juniper logs it just says:

Request to connect to 10.43.40.82 port 3389 permission denied

But there is nothing wrong with the desktop. The user does have rights and is admin on the box.

Anybody have any ideas?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Contributor

Re: Terminal Service Client - Permission Denied

Sound like you forgot to add the corresponding ACL's

Go to Resource Policies > Terminal Services (or SAM or NC depening on your access method) > Access control and add: Resource 10.43.40.82:3389

Action: Allow Access

If you setup the resource via Resource Profiles, you can simply tick thecheckbox:

"Create an access control policy allowing Terminal Service access to this server"

View solution in original post

4 REPLIES 4
Highlighted
Frequent Contributor

Re: Terminal Service Client - Permission Denied

Hi,

If you can RDP to them internally, there are a few things to check. First, are you using Network Connect and the local RDP client or the Juniper RDP client (Terminal Services Bookmark)? I would make sure there is a policy for the resources you're trying to RDP to. Check "Users, Resource Policies, Network Connect or Terminal Services". Make sure you have an Access Policy for the resources (i.e. 192.168.1.0/24:3389) and apply it to the proper role.

Highlighted
Contributor

Re: Terminal Service Client - Permission Denied

Sound like you forgot to add the corresponding ACL's

Go to Resource Policies > Terminal Services (or SAM or NC depening on your access method) > Access control and add: Resource 10.43.40.82:3389

Action: Allow Access

If you setup the resource via Resource Profiles, you can simply tick thecheckbox:

"Create an access control policy allowing Terminal Service access to this server"

View solution in original post

Highlighted
Contributor

Re: Terminal Service Client - Permission Denied

@123go, thanks. I beleive this is the problem. Won't know until tomorrow. I will update at that time.

Highlighted
Contributor

Re: Terminal Service Client - Permission Denied

thank you guys, that has solved the problem. I will know in the future to copy a profile so I won't miss any settings.

Much appreciated.