cancel
Showing results for 
Search instead for 
Did you mean: 

Terminal Service does not work for Home Office

tnguyendoit
Occasional Contributor

Re: Post-9.1R11.3 upgrade client-side steps

olibouli,

 

Did you uninstall all 4:

 

Pulse Application Launcher
Pulse Secure Host Checker
Pulse Secure Setup Client
Pulse Secure Terminal Services Client

 

as the user

 

then go through the process as the user to get new PSAL --> Pulse Setup Client --> Host Checker --> TS Client installed?

 

TS worked fine for me...

Tags (1)
nijhunter
Occasional Contributor

Re: Post-9.1R11.3 upgrade client-side steps

From the first returns, i prefered to postpone the upgrade to tomorrow....

 

Strange behavior, the package provided can't be staged. I upload it on each node, and it doesn't appear into the staging area.

 

What are you doing Pulse ???

olibouli
Occasional Contributor

Re: Post-9.1R11.3 upgrade client-side steps

I did the manual removal again, you were right TNGUYENDOIT !

I can also confirm that migrating from PCS release 9.1R11.1 to 9.1R11.3 also successfully solved broken Terminal services Remote Desktop sessions.

Many thanks for advices.

 

olibouli
Occasional Contributor

Re: Post-9.1R11.3 upgrade client-side steps

 NIJHUNTER,I did it through the staged area and noticed the same behavior : doesn't appear into the staging area ! 

but after that, choosed "From Staged Package" nevertheless and the upgrade worked well.

kkullot
Occasional Contributor

Re: Post-9.1R11.3 upgrade client-side steps

Question to those in regards to upgrade:

 

After you upgrade the server appliance to 9.1R11.3 do you need to uninstall those components from devices that use the Pulse Secure Client?   Or when you launch the Pulse Secure Client will it prompt to upgrade and do all those steps?  

 

Another question:  If the above answer is no then can we update the appliance and then disable the option to auto update the clients and instead push out the update to clients?   

 

My biggest concern with this upgrade is our current users that use the client app to login.  They are having no issues.  The ones with the issues are home users that use the web browser.  I don't want to break the users currently working.   

 

I have over 100 connected to VPN so breaking them would be disastrous on our Help Desk team. 

 

Any advice would be great!  

rvandolson
Occasional Contributor

Re: Post-9.1R11.3 upgrade client-side steps

How are all of you handling this to make it as low touch as possible for your user base?  We have 3,000+ users and rely on both Host Checker and the Application Launcher.  We support connecting via a web portal (SSO) and directly (most everyone is using this as a workaround now of course).

 

The 'fix' process seems to be:

  1. Upgrade PSC Server to 9.1R11.3.
  2. Clients connect and get new client automatically.
  3. Clients must now run uninstall script (we have a custom one since the script provided by Support in the KB only uninstalls the application launcher and has other bugs)
  4. Now clients can reconnect and will get the updated, properly signed helper executables.

Above is pretty wonky and not user friendly.  We're thinking we could perhaps use SCCM to push out the new client and helper components, but presumably we end up in a race condition then with the new clients connecting to the old server (we're on 9.1R11) and getting forced to the old helper components again.

 

How do we best avoid having to hand touch each of our users?

Maex
Occasional Contributor

Re: Post-9.1R11.3 upgrade client-side steps

Hello,

 

we have installed the PDC for our internal clients via SCCM.

Current version on the clients is 9.1.10.5655.

Since the server upgrade to 9.1R11.3 our clients get the offer to upgrade the PDC on every connect, but we did not set the Default components 9.1.11.8389 as active but the manually uploaded version 9.1.10.5655 (as on the client).

So the client must not pop up the upgrade window.

We actually disabled the web upgrade feature, but need this for other users where we cannot use the SCCM installation method.

Any idea how to fix this?

 

Also the installers section does not show the same version (9.1.10.5655) as the the components section (9.1.11.8389).

As of the revision number of the MSI, downloaded from the installers section, it is really the 9.1.10.5655

 

Awful week :-(

 

BR
Maex