cancel
Showing results for 
Search instead for 
Did you mean: 

Ubuntu (Pop OS 20.04) install + loading issues

Highlighted
New Contributor

Ubuntu (Pop OS 20.04) install + loading issues

My initial issue was resolved by this solution:

https://community.pulsesecure.net/t5/Pulse-Desktop-Clients/Unable-to-install-on-Ubuntu-18-04-PopOS/m...

 

Then after running the final command from the above post, this is the output

(Reading database ... 319329 files and directories currently installed.)
Preparing to unpack pulse-fixed.deb ...
/var/lib/dpkg/info/pulse.prerm: line 216: [: =: unary operator expected
/var/lib/dpkg/info/pulse.prerm: line 218: [: =: unary operator expected
Do you want to clean up the configuration? [Yy/Nn] y
Unpacking pulse (9.1R2-69) over (9.1R2-69) ...
Setting up pulse (9.1R2-69) ...

Pulse Secure is now listed as a program in my computer.  However, when trying to open, there is no response from the program (i.e. there is no GUI that appears.)

 

What are the next steps for opening Pulse Secure?

2 REPLIES 2
Highlighted
Frequent Contributor

Re: Ubuntu (Pop OS 20.04) install + loading issues

Hi,

 

Probably of you do a ldd on pulseUi, you will see libwebkitgtk-1.0.so.0 is not installed.

$ ldd /usr/local/pulse/pulseUi

 

To fix it, you just need to add Bionic Beaver (18.04 LTS) repository (or adapt to PopOS)

# add-apt-repository 'deb http://archive.ubuntu.com/ubuntu bionic main universe'

Then install the missing package.

# apt install -t bionic libwebkitgtk-1.0-0

Tested with Pulse Secure 9.1R4

Highlighted
Moderator

Re: Ubuntu (Pop OS 20.04) install + loading issues

@B-E_Susan Pulse UI will not be displayed in case of any missing dependency packages, please review @flipPipe's update, and see if that helps.

PCS Expert
Pulse Connect Secure Certified Expert