cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to connect when adding Hyper-V Wi-Fi adapter

LukasA
New Contributor

Unable to connect when adding Hyper-V Wi-Fi adapter

Hi,

 

Since few months, I'm not able to connect to Pulse VPN anymore on my host when I create an external Wi-Fi adapter for my VM, using Hyper-V. When I delete this freshly created adapter, the VPN connectivity works well.

 

When I create this adapter into Hyper-V then try to connect through the VPN, the VPN stay in cancellable pending state. I have the three following lines repeatly in the log file:

 

00162,09 2020/10/14 15:59:39.221 3 dsHostChecker.exe hcUtils hcProcessUtils.cpp:76 - 'ProcessUtil::Constructor' Static members are already initialized
00154,09 2020/10/14 15:59:39.230 1 dsHostChecker.exe hcUtils hcPrivileges.cpp:42 - 'SetPrivilege' Unable to AdjustTokenPrivileges. Error 0x514
00154,09 2020/10/14 15:59:39.230 1 dsHostChecker.exe hcUtils hcPrivileges.cpp:42 - 'SetPrivilege' Unable to AdjustTokenPrivileges. Error 0x514

 

The drivers are well installed.

Have you any idea why am I facing this issue?

 

Thanks for your help.

3 REPLIES 3
r@yElr3y
Moderator

Re: Unable to connect when adding Hyper-V Wi-Fi adapter

@LukasA dsHostChecker.exe is the process that gets created when using browser to connect, are you using browser or pulse client?

 

when you capture the traffic from the hyper-v interface and on the external wifi interface, do you see TCP/SSL communication between Hyper-V and VPN server?

PCS Expert
Pulse Connect Secure Certified Expert
LukasA
New Contributor

Re: Unable to connect when adding Hyper-V Wi-Fi adapter

I use the Pulse client v.9.1.4 (1883), on both host and VM.

 

When I connect to VPN from my VM (it's working fine), I get the following packet on connection and disconnection:

  • Protocol. SSDP | Info. M-SEARCH * HTTP/1.1

 

When I connect to VPN from my host (which is not working), I don't catch anything on the VM through the network interface.

 

For information, my host is using Wi-fi (wireless connection), where my VM use an Ethernet interface. The configuration is the following:

  1. vEthernet (Wi-Fi) | Connected to my internet box, used by the VM | Hyper-V virtual Ethernet
  2. Wi-Fi | Activated and linked by a bridge | Intel(R) Wireless-AC... (wifi driver)
  3. Network Bridge | Connected | Microsoft Network Adapter

 

Regards,

 

 

r@yElr3y
Moderator

Re: Unable to connect when adding Hyper-V Wi-Fi adapter

@LukasA When you create this External WiFi adapter for the Hyper-V guests, do you see the WiFi adapter present on the host machine has valid IP address and stuffs? I think it'll say "Not connected" and managed by the virtual bridge that was created.

 

If that's the case, then I think the Pulse Client might be looking for an actual physical interface presence something like WiFi or LAN connection to trigger the VPN connection, and in our case, it's now Network-Bridge(Mutliplexor adapter), correct?

 

Pulse Client maybe seeing the network bridge as virtual interface not as physical and just waiting for you to bring the WiFi interface up.

 

Can you see if the setup is working when create something like a host-only adapter or NAT adapter, in that way the WiFi adapter will be connected and the Hyper-V will share the connection or create a new network from the guests. But downside of using host-only is that the guest will not connecting to Internet anymore.. but NAT type should be good. right?

 

 

 

PCS Expert
Pulse Connect Secure Certified Expert