cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to launch your application.

SOLVED
Highlighted
Occasional Contributor

Unable to launch your application.

Juniper SSL VPN

version 7.1 R3 (build 18671)

We configured our Citrix Web Interface to run under Web Bookmarks on the Juniper Appliance for SSL VPN. We have several users reporting an error message when the try to launch a published icon via Internet Explorer. The error is "Unable to launch your application. Cannot connect to the Citrix XenApp server. The Citrix XenApp server you have selected is not accepting connections."

We've tried Add/Remove of Juniper and Citirx components, modifying Active X and other settings in IE to no avail. IE versions 7, 8 and 9 have been tested and failed. We can create a new profile on the same laptop and/or desktop and it will work 90% of the time. Google Chrome works as well. But for some reason when IE breaks, it's broken and creating a new profile isn't really a fix we'd like to recommend. Especially to our external users.

Has anyone experienced anything like this?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Occasional Contributor

Re: Unable to launch your application.

I know it's been some time but Thank you!  This resolved my issue.  After working with JTAC and not being able to resolve this issue, I thought I was lost.  I can't tell you how much time was spent in this.  I guess that's why we have forums.  Thanks again!

View solution in original post

3 REPLIES 3
Highlighted
Regular Contributor

Re: Unable to launch your application.

How is the Citrix resource configured?

is through Wsam/JSAM/CTS?

If through CTS is the IVE url in trusted sites?

IF the Ive URL is in trusted sites please refer the following KB

http://kb.pulsesecure.net/KB18241

please mark this post as 'accepted solution' if this answers your question that way it might help others as well, a kudo would be a bonus thanks

Highlighted
Occasional Contributor

Re: Unable to launch your application.

I know it's been some time but Thank you!  This resolved my issue.  After working with JTAC and not being able to resolve this issue, I thought I was lost.  I can't tell you how much time was spent in this.  I guess that's why we have forums.  Thanks again!

View solution in original post

Highlighted
Respected Contributor

Re: Unable to launch your application.

glad to hear it worked; thank you for the update on this so others know it works as well