cancel
Showing results for 
Search instead for 
Did you mean: 

Vista and Citrix

Occasional Contributor

Vista and Citrix

I noticed that Citrix was very slow when using vista. I also noticed that users need a Citrix ICA client of at least version 10.00 How do I ensure that I have the correct version in the IVE (in otherwords that the IVE's link http://download2.citrix.com/FILES/en/products/CPSICAClientsMulti/icaweb.cab is the correct one)? I am running an SA4000 with 6.0R3 (we just upgraded a couple of months ago.)
3 REPLIES 3
Occasional Contributor

Re: Vista and Citrix

Should I be using the following for Vista/XP: http://www.citrix.com/English/SS/downloads/details.asp?dID=2755&downloadID=1339765&pID=186#top

Citrix Presentation Server Web Client 10.200

I noticed that the default link in the IVE produces a CAB with a different md5sum, than the cab which can be downloaded here.

Highlighted
Occasional Contributor

Re: Vista and Citrix

So I have done some testing, and it seems like a lot of Vista clients have the same problem. The CAB file downloaded is the OLD version. I uploaded a new version of the CAB 10.200 from the Citrix website, selected the uploaded CAB to be used, but it's still downloading the old version of the client when I click on the Citrix bookmark. Manually installing the MSI from the same web page for 10.200 allows Citrix to work OK.
Occasional Contributor

Re: Vista and Citrix

Hi emrecio, did you ever got to the bottom of this? The link in the SA web GUI now appears to be broken, and I can't find icaweb.cab anywhere. I can get .msi versions, but do you need a citrix.com login to get the .cab?

Cheers, J