cancel
Showing results for 
Search instead for 
Did you mean: 

Works with IE, Firefox, not Chrome or Edge

Highlighted
New Member

Works with IE, Firefox, not Chrome or Edge

I'm trying to determine why I am able to connect to my remote computer using old Internet Explorer or FIrefox, but not with the Chrome or Edge browser.

 

Chrome and Edge just say "Searching for the Application Launcher..." and spins with a countdown of 60 seconds.

 

With Process Monitor I can see the Internet Explorer and Firefox are launching PulseApplicationLauncher.exe, whereas Chrome and Edge never get that far.

 

For example, on Chrome I get:

 

"Time of Day","Process Name","PID","Operation","Path","Result","Detail"
"12:04:47.0151923 PM","chrome.exe","1852","RegOpenKey","HKCR\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\PackageRepository\Extensions\windows.protocol\pulsesecure","NAME NOT FOUND","Desired Access: Read"
"12:04:47.0152769 PM","chrome.exe","1852","RegOpenKey","HKCU\Software\Classes\pulsesecure","SUCCESS","Desired Access: Read"
"12:04:47.0153148 PM","chrome.exe","1852","RegOpenKey","HKCU\Software\Microsoft\Windows\Shell\Associations\UrlAssociations\pulsesecure","NAME NOT FOUND","Desired Access: Read"
"12:04:47.0153715 PM","chrome.exe","1852","RegOpenKey","HKCU\Software\Classes\pulsesecure","SUCCESS","Desired Access: Read"
"12:04:47.0153854 PM","chrome.exe","1852","RegQueryKey","HKCU\Software\Classes\PulseSecure","SUCCESS","Query: Name"
"12:04:47.0153988 PM","chrome.exe","1852","RegQueryKey","HKCU\Software\Classes\PulseSecure","SUCCESS","Query: HandleTags, HandleTags: 0x0"
"12:04:47.0154153 PM","chrome.exe","1852","RegQueryKey","HKCU\Software\Classes\PulseSecure","SUCCESS","Query: HandleTags, HandleTags: 0x0"
"12:04:47.0154288 PM","chrome.exe","1852","RegOpenKey","HKCU\Software\Classes\PulseSecure\CurVer","NAME NOT FOUND","Desired Access: Query Value"
"12:04:47.0154439 PM","chrome.exe","1852","RegOpenKey","HKCR\PulseSecure\CurVer","NAME NOT FOUND","Desired Access: Query Value"
"12:04:47.0154619 PM","chrome.exe","1852","RegQueryKey","HKCU\Software\Classes\PulseSecure","SUCCESS","Query: Name"
"12:04:47.0155276 PM","chrome.exe","1852","RegQueryKey","HKCU\Software\Classes\PulseSecure","SUCCESS","Query: HandleTags, HandleTags: 0x0"
"12:04:47.0155393 PM","chrome.exe","1852","RegQueryKey","HKCU\Software\Classes\PulseSecure","SUCCESS","Query: HandleTags, HandleTags: 0x0"
"12:04:47.0155520 PM","chrome.exe","1852","RegOpenKey","HKCU\Software\Classes\PulseSecure","SUCCESS","Desired Access: Read"
"12:04:47.0155700 PM","chrome.exe","1852","RegCloseKey","HKCU\Software\Classes\PulseSecure","SUCCESS",""
"12:04:47.0155896 PM","chrome.exe","1852","RegQueryKey","HKCU\Software\Classes\PulseSecure","SUCCESS","Query: Name"
"12:04:47.0156038 PM","chrome.exe","1852","RegQueryKey","HKCU\Software\Classes\PulseSecure","SUCCESS","Query: HandleTags, HandleTags: 0x0"
"12:04:47.0156137 PM","chrome.exe","1852","RegQueryKey","HKCU\Software\Classes\PulseSecure","SUCCESS","Query: HandleTags, HandleTags: 0x0"
"12:04:47.0156529 PM","chrome.exe","1852","RegOpenKey","HKCU\Software\Classes\PulseSecure\Progid","NAME NOT FOUND","Desired Access: Query Value"
"12:04:47.0156673 PM","chrome.exe","1852","RegOpenKey","HKCR\PulseSecure\Progid","NAME NOT FOUND","Desired Access: Query Value"
"12:04:47.0156856 PM","chrome.exe","1852","RegCloseKey","HKCU\Software\Classes\PulseSecure","SUCCESS",""
"12:04:47.0156980 PM","chrome.exe","1852","RegCloseKey","HKCU\Software\Classes\PulseSecure","SUCCESS",""

 

and that's the end of it. Chrome doesn't go any further, whereas Firefox and IE continue with a lot more which includes launching PulseApplicationLauncher.exe

 

Windows 10 Home

Google Chrome Version 84.0.4147.105 (Official Build) (64-bit)

Edge Version 84.0.522.52 (Official build) (64-bit)

Firefox 79.0 (64-bit)

IE 11.959.18362.0

 

1 REPLY 1
Highlighted
Moderator

Re: Works with IE, Firefox, not Chrome or Edge

@deley  Do you see HKCU\Software\Classes\pulsesecure contents through the registry editor?

 

Registry path - Computer\HKEY_CURRENT_USER\Software\Classes\PulseSecure >> collapse "shell" >> collapse "open" >> collapse "command" >> with string value as "C:\Users\rayappan\AppData\Roaming\Pulse Secure\PSAL\PulseApplicationLauncher.exe" %1

 

Interesting fact is the same protocol handler (pulsesecure://) should be used by non-IE browsers, hence if Firefox able to find it, why not Chrome? ProcMon log shows that the Chrome is attempting to read the contents of the protocol hander reg keys, but still doesn't launch PSAL.

 

Are you using personal or work device?

do you see the same behavior in any of your other workstations? probably, should not.

Maybe uninstall/reinstall PSAL?

PCS Expert
Pulse Connect Secure Certified Expert