cancel
Showing results for 
Search instead for 
Did you mean: 

XenDesktop 5.1 via Virtual Desktop Profile on SA with 7.0R4

Frequent Contributor

XenDesktop 5.1 via Virtual Desktop Profile on SA with 7.0R4

Hi All, I was wondeirng if anyone if using this setup? We are trying to use the Virtual Desktop Profiles to create a link into our XenDesktop setup and get an immediate error message that says "Unable to load Citrix Desktops, please contact your administrator". I've got the IVE setup just as the docs suggest... When I talked to the Citrix consultant, he thinks it may be because Citrix made some big changes on the last update and the built-in Juniper calls may not be accurate anymore... If you've got it to work, can you tell me how? (and speaking to me like I'm 5 may be necessary for this one..) Thanks. -Stephen
17 REPLIES 17
Contributor

Re: XenDesktop 5.1 via Virtual Desktop Profile on SA with 7.0R4

No thats what I mean, my issue is with a Virtual Desktop profile.

I just don't get your question about the web application profile. Sorry for the confusion.

Contributor

Re: XenDesktop 5.1 via Virtual Desktop Profile on SA with 7.0R4

I'm trying to do the same thing, but I'm running the latest at 7.1R2 which was released today I believe. I get the same error and it appears that with a tcpdump, the XML the SA sends is not correct, though I don't know what it is suppose to be. Here is the XML POST and response:

From SA to Xendesktop POST at http://xendesktop/scripts/wpnbr.dll:

<?xml version="1.0" encoding="ISO-8859-1" ?>

<!DOCTYPE NFuseProtocol SYSTEM "NFuse.dtd">
<NFuseProtocol version="5.0">
<RequestAppData>
<Scope traverse="subtree"></Scope>
<DesiredDetails>all</DesiredDetails>
<AppName></AppName>
<ServerType>all</ServerType>
<ClientType>ica30</ClientType>
<Credentials>
<UserName>admin</UserName>
<Password encoding="cleartext">passwd</Password>
<Domain type="NT">domain</Domain>
</Credentials>
</RequestAppData>
</NFuseProtocol>

the response from xendesktop:

<?xml version="1.0" encoding="ISO-8859-1"?>
<!DOCTYPE NFuseProtocol SYSTEM "NFuse.dtd">
<NFuseProtocol version="5.1">
<ResponseAppData>
<ErrorId>unspecified</ErrorId>
</ResponseAppData>
</NFuseProtocol>

Is it because of the protocol version mismatch? Does 7.1 not yet support Xendesktop 5.1 with Virtual Desktop profiles? Creating a web profile for citrix works fine for this though.

Regular Contributor

Re: XenDesktop 5.1 via Virtual Desktop Profile on SA with 7.0R4

do you have terminal services enabled for the role?

i also know that 7.1R1 made some changes for citrix, im trying to find them now

here's a few,

Terminal Services
¥ In case of user getting mapped to multiple roles, only one roleÕs settings for the user experience options of Terminal services configured at the role level, will be effective. (499990)
¥ For Citrix WI 5.1, the cookie value does not get saved when creating new profiles unless Send the following data as request headersÓ checkbox is enabled. (532110)


VDI
¥ For Vmware / Citrix client uploading, the maximum size of the package has been increased to 25MB.
¥ When a new SA is installed/ IVS instance created, the defaults for system-level VDI download URLs (System > Configuration > Virtual Desktops > VMware and System > Configuration > Virtual Desktops > Citrix) and role-level Terminal Service download URL (Users > User Roles > User Role > Terminal Services > Options will be set to blank. The administrator needs to set it to an appropriate URL (491211

Frequent Contributor

Re: XenDesktop 5.1 via Virtual Desktop Profile on SA with 7.0R4

What's all needed in the Terminal Services Profile? Just Access Rules, or do we actually need a bookmark for something? Thanks. -Stephen.
Regular Contributor

Re: XenDesktop 5.1 via Virtual Desktop Profile on SA with 7.0R4

just tick the checkbox is all i did and under options enable download from citrix website and i use http://www.citrix.com/English/ss/downloads/results.asp?productId=163057 as the path

Contributor

Re: XenDesktop 5.1 via Virtual Desktop Profile on SA with 7.0R4

Well I get the error "Warning: Unable to retrieve desktop list, please re-check the server configuration in the Profile" when I create the Virtual Desktop profile and edit the bookmark. It can't download the list of desktops and it sends that XML I noted above. So this is all before even attempting as a user.

Regular Contributor

Re: XenDesktop 5.1 via Virtual Desktop Profile on SA with 7.0R4

have you created the web application resource profile and selected Citrix Web Interface/JICA and the rest of those fields?

Contributor

Re: XenDesktop 5.1 via Virtual Desktop Profile on SA with 7.0R4

This is about the Virtual Desktop profiles, not a wep app profile.

But I did try the web application profile for citrix and it does work fine with xendesktop. But we're talking about the Virtual Desktop profile.

Regular Contributor

Re: XenDesktop 5.1 via Virtual Desktop Profile on SA with 7.0R4

oh sorry, i was replying to the original posters issue with virtual desktop, instead try making a thread specific to your issue.