cancel
Showing results for 
Search instead for 
Did you mean: 

"Pulse Secure Application Launcher failed to load Java. Please install correct JRE version."

michael92
New Member

"Pulse Secure Application Launcher failed to load Java. Please install correct JRE version."

I am trying to RDC via Pulse Secure Application Launcher. I keep getting

 

"Pulse Secure Application Launcher failed to load Java. Please install correct JRE version."

 

I am running macOS 11.0.0

 

Java is installed, is on my path, and JAVA_HOME is set

 

[email protected] ~ % java -version 
openjdk version "1.8.0_275"
OpenJDK Runtime Environment (Zulu 8.50.0.1013-CA-macos-aarch64) (build 1.8.0_275-b01)
OpenJDK 64-Bit Server VM (Zulu 8.50.0.1013-CA-macos-aarch64) (build 25.275-b01, mixed mode)
[email protected] ~ % echo $JAVA_HOME 
/Users/michael/java/jdk8/zulu8.50.0.1013-ca-jdk8.0.275-macos_aarch64/bin/

Where is Pulse trying to find Java? Are there any logs I can view?

I have seen https://community.pulsesecure.net/t5/Pulse-Connect-Secure/MacOS-10-14-unable-to-connect-in-need-of-c... but unfortunately it is not useful, since Java is installed

6 REPLIES 6
jspiegel
New Contributor

Re: "Pulse Secure Application Launcher failed to load Java. Please install correct JRE version.

I don't know if it is the same issue, but I know there is an ongoing issue with the latest version of the JRE 271, and PAL only works for me if I revert back to JRE 251 (still with some issues like random crashes, and does not work on multiple monitors). This is a two month old issue, but Pulse has not done anything about it to my knowledge.

r@yElr3y
Moderator

Re: "Pulse Secure Application Launcher failed to load Java. Please install correct JRE version.

@michael92 Please review the PulseApplicationLauncher.log and check the function which is failing. Launcher log should be in ~/Library/Logs directory.

PCS Expert
Pulse Connect Secure Certified Expert
jspiegel
New Contributor

Re: "Pulse Secure Application Launcher failed to load Java. Please install correct JRE version.

How can I send the application logs privately? I don't want to post it in the message board since it is public.

 

thanks,

MGall
Occasional Visitor

Re: "Pulse Secure Application Launcher failed to load Java. Please install correct JRE version.

I'm having this problem as well.  I have not been able to get Pulse to launch at all. 

r@yElr3y
Moderator

Re: "Pulse Secure Application Launcher failed to load Java. Please install correct JRE version.

@michael92 @jspiegel Please request your helpdesk team to open a support ticket with us for review. DM through forum has been disabled temporarily.

PCS Expert
Pulse Connect Secure Certified Expert
arcanerr
New Contributor

Re: "Pulse Secure Application Launcher failed to load Java. Please install correct JRE version.

It would be utterly helpful if the stupid error message part "Please install correct JRE version" would instead be something like
Please install ORACLE Java 11

or

Please install one of the following supported Java versions

  • OpenJDK xx.yy, zz.aa
  • ORACLE Java uu.vv
  • ...