cancel
Showing results for 
Search instead for 
Did you mean: 

Big trouble after upgrading from 9.1R1 to 9.1R3

Highlighted
New Contributor

Big trouble after upgrading from 9.1R1 to 9.1R3

Last weekend, we performed the upgrade of our platform from the version 9.1R1 to 9.1R3.
The client is supposed to be upgraded automatically to match with the server's version.
For some users, the client upgrade were failed and those users were not able to connect to the VPN the usual way.
When they try to connect to the VPN from the Pulse client, the moment when Pulse client launch the connection, the connection disappears and the message "The Pulse Secure Service is not running" is shown in the Pulse client.


The user has to close the Pulse client then re-open it then the connection starts to work. But every time they want to connect, they have to repeat this steps.
We tried to remove the Pulse Secure Client and reinstall it but it does not solve the issue.

To fix this, we have to uninstall all the Pulse components (client, host-checker, installer service, activex, ...) then reinstall the Installer Service and then Pulse Client (by going to the VPN site).
After that it starts to work again.

For some users it's even not possible to uninstall and reinstall the client (it keeps rolling back at the uninstallation/installation).

We have this issue on windows 10 PC (1803).

 

Can somebody please help ? we already open a case with Pulse but it will take time for sure.

3 REPLIES 3
Highlighted
New Contributor

Re: Big trouble after upgrading from 9.1R1 to 9.1R3

Can anyone please help ?

Highlighted
Occasional Visitor

Re: Big trouble after upgrading from 9.1R1 to 9.1R3

Hi, just came here to say I have the exact same problem after my company rolled out an upgrade from 9.1.1 to 9.1.3. When I attempt to connect I get the same "The Pulse Secure Service is not running"  issue.

 

I can get around it by doing the following in order after attempting to log in:

 

1.) closing the client

2.) ending all background Pulse Tasks

3.) stopping the Pulse service

4.) starting the client

4.) restarting the service

 

It then connects without prompting for credentials. 

 

Obviously this is far from ideal and would be intersted in a solution from Pulse

 

Thanks

Tim

 

 

Highlighted
New Contributor

Re: Big trouble after upgrading from 9.1R1 to 9.1R3

Checking to see if anyone has had success in figuring this out. After enabling hostchecker on a realm, we're beginning to see this behavior on some Windows clients when logging in from the Web to the IVE. In what I've observed, if the Pulse client is closed, then the PSAL is able to launch the client and the L3 tunnel completes successfully. Until I log out of the PSA connection and attempt to log back in. However, if the connection is initiated directly from Pulse, the connection works every time - the issue only occurs if logging in via web browser that initiates the L3 connection with hostchecker enabled.

 

Also of note, Windows Event Application log has an msiinstaller error coinciding with the failed login/connection attempt. The pair of messages is to the effect that the Pulse Secure Installer Service - Installation Failed, and "You do not have sufficient privileges to complete this installation for all users of the machine. Log on as administrator and then retry this installation." I've been able to reproduce this on test machines where I am the admin user, as well as testing on a non-domain endpoint with the same result.

 

Just checking if there's any insight as I also work to open a ticket.