cancel
Showing results for 
Search instead for 
Did you mean: 

Fedora 27 - webkitgtk no longer supported

SOLVED
New Contributor

Re: Fedora 27 - webkitgtk no longer supported

Hello Jamey

Really I put the execution using the terminal because using the desktop icon the application isn't opened too.

I make the test with the terminal trying to know what's the error that avoid the app opening.

The cat shows me exactly same info that you wrote in your post.

 

Any other idea?

Thanks in advance

Alberto

Highlighted
Occasional Contributor

Re: Fedora 27 - webkitgtk no longer supported

Do you see any dependency issues or complaints when running the dependency install script?

 

sudo /usr/local/pulse/PulseClient_x86_64.sh install_dependency_packages

Only thing I can think of at the moment.

New Contributor

Re: Fedora 27 - webkitgtk no longer supported

i have the same issue. here is the output the dependencies utility

/usr/local/pulse/PulseClient.sh install_dependency_packages
Checking for missing dependency packages ...
webkitgtk is missing in the machine
mozjs17 is missing in the machine
libproxy-mozjs is missing in the machine
libproxy-gnome is missing in the machine

some dependencies are already installed

dnf install mozjs17
Failed to synchronize cache for repo 'atlassian-hipchat', disabling.
Last metadata expiration check: 0:27:32 ago on Thu 07 Dec 2017 06:33:58 PM EST.
Package mozjs17-17.0.0-21.fc27.x86_64 is already installed, skipping.
Dependencies resolved.
Nothing to do.
Complete!
dnf install libproxy-mozjs
Failed to synchronize cache for repo 'atlassian-hipchat', disabling.
Last metadata expiration check: 0:28:31 ago on Thu 07 Dec 2017 06:33:58 PM EST.
Package libproxy-mozjs-0.4.15-4.fc27.x86_64 is already installed, skipping.
Dependencies resolved.
Nothing to do.
Complete!

some were missing 

 

Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                 1/1 
  Installing       : libproxy-gnome-0.4.15-4.fc27.x86_64                                             1/1 
  Verifying        : libproxy-gnome-0.4.15-4.fc27.x86_64                                             1/1 

Installed:
  libproxy-gnome.x86_64 0.4.15-4.fc27                                                                    

Complete!

 

the icon is still not working 
and the command line is complaining about a missing dependency

./pulseUi
./pulseUi: error while loading shared libraries: libwebkitgtk-1.0.so.0: cannot open shared object file: No such file or directory
New Member

Re: Fedora 27 - webkitgtk no longer supported

For what it's worth, the newest version of the client (5.3R4.0) doesn't work, either, given that it has the same dependency.   --Jeff

Occasional Contributor

Re: Fedora 27 - webkitgtk no longer supported

@isbenj try also installing this webkitgtk. 

 

webkitgtk-2.4.11-5.fc26.x86_64.rpm

 

installation of xulrunner goes fine.

rpm -ivh webkitgtk-2.4.11-5.fc26.x86_64.rpm

 Oh! never mind, my bad, Thats what I tried first. This makes things a little weird. Instead, on Page one of this Post. Find the 5 step instructional on how to get the required Libraries needed from webkitgtk. That will do it for you.

Occasional Contributor

Re: Fedora 27 - webkitgtk no longer supported

@kita are we aware of any progress for this yet, we did find a pretty harsh work around to make it work as you can follow along in this post. But a true Install that just works would still be great!

New Contributor

Re: Fedora 27 - webkitgtk no longer supported

i uninstalled my current version and reinstalled . after the 5 steps completed, i'am able to run the UI.
thanks

Occasional Contributor

Re: Fedora 27 - webkitgtk no longer supported

Hi, @kita This issue has been going for a reasonable amount of time now. We have figured out a work around. I hope those who need it due find this post and understand it with ease. What is the current status of an official fixed though?

Community Manager

Re: Fedora 27 - webkitgtk no longer supported

@jamey Thank you for your continued feedback. We have been working on a permanent fix for Fedora 27 and the webkit issue. We should have more details upcoming major release. I can update this thread in the coming weeks once everything is confirmed.

New Contributor

Re: Fedora 27 - webkitgtk no longer supported

Thanks @kita,

 

Do you have any update about the new Release? Or that Release is the deployment of Fedora 28?

 

Regards