cancel
Showing results for 
Search instead for 
Did you mean: 

Fedora 30 compatibilty

New Contributor

Fedora 30 compatibilty

Please update the client to support Fedora 30, a lot of packages needed by the client are now deprecated. i.e.: webkitgtk, xulrunner, mozjs17
Also the pulseUI wont start because missing packages:

$ ldd /usr/local/pulse/pulseUi | grep not
libicui18n.so.57 => not found
libicuuc.so.57 => not found
libicudata.so.57 => not found
libicui18n.so.57 => not found
libicuuc.so.57 => not found
libicudata.so.57 => not found

 

libicu-63 is currently maintained, you should upgrade you client to use it.

 

My company is paying you for your support, please fix your linux clients.

6 REPLIES 6
Highlighted
New Member

Re: Fedora 30 compatibilty

Hi. There is an easier way to use the pulse secure vpn on Fedora 30 using Network Manager:

First erase the pulse rpm with dnf. It isn't maintained and it's not worth the effort.

Then use the following click sequence:

Networks (little monitor icon in system tray)
Configure Network connections...  (settings icon)
+ (add new connection)
Juniper SSL VPN / Pulse connect secure
Create
... set the name and the gateway ....
Save
OK
Then to use it click the same icon and click connect. If you have two factor authentication (we do) put "push" in the 2nd password for a push to your phone.

Good luck!

Highlighted
New Contributor

Re: Fedora 30 compatibilty

Hi,

What display manager are you using?

I'm on Gnome and there aren't options you described, and if I am trying to configure the VPN the connection fails with auth errors(it doesn't even ask me for credentials..)

 

IIRC network manager is really buggy on gnome, in the past I tried to use it with not much success.

Highlighted
New Member

Re: Fedora 30 compatibilty

Same problem. Manual workaround does not work. Please update the client!

Highlighted
New Member

Re: Fedora 30 compatibilty

Hi beleagured pulsesecure Fedora users,

 

I have found a workaround. As noted by the last post, there are dependencies such as

 
libicui18n.so.57 => not found
libicuuc.so.57 => not found
libicudata.so.57 => not found
 
To find them, I downloaded an old package of libicu57 from
 
 
although any centos or fedora version 57 rpm would have worked here, this was the first one I found.
 
Then, after extracting using the rpm2cpio libicu57-57.1-8.el7.x86_64.rpm | cpio -idmv command, the three .so files appear in /usr/lib64 (in the location that you extracted these files).
 
A copy-paste of the symlinks that were not found to your own /usr/lib64 allows the .pulseUi to launch (e.g. cp libicuuc.so.57 /usr/lib64, assuming you are in the place you extracted the rpm).
Highlighted
New Member

Re: Fedora 30 compatibilty

Thanks!! this worked also for fedora 31.

 

ldd /usr/local/pulse/pulseUi | grep not              
       libicui18n.so.57 => not found
       libicuuc.so.57 => not found
       libicudata.so.57 => not found
       libicui18n.so.57 => not found
       libicuuc.so.57 => not found
       libicudata.so.57 => not found

 

Downloaded the RPM -> extracted -> moved these files from extracted RPM to /usr/local/pulse/

 

problem solved

Highlighted
New Member

Re: Fedora 30 compatibilty


If you have two factor authentication (we do) put "push" in the 2nd password for a push to your phone.

Where in the world do you see an input for a 2nd password? What setting enables this in the NetworkManager configuration dialog? I've tried everything I can think of to input this value on Fedora 30 & 31.