cancel
Showing results for 
Search instead for 
Did you mean: 

Invalid HASH_R

Highlighted
Occasional Contributor

Invalid HASH_R

I've poked and prodded

Uninstalled/Reinstalled

Rebooted

Searched for hidden configs to delete.

I can't figure this out.

 

I've got an account on a Windows domain.  Running Windows 10.  I get an error in the debuglog; somehow the Hash_R is incorrect.  Here is a a snippet from my log:

 

00210,09 2019/05/15 12:17:15.920 3 SYSTEM PulseSecureService.exe dsTMService p5780 t91C mLog.cpp:324 - 'TM' New C_Peer Created UID=00000001 to XXX.XXX.XXX.XXX: local-port(52158) remote-port(500) on Interface UID=00000001
00213,09 2019/05/15 12:17:15.920 3 SYSTEM PulseSecureService.exe dsTMService p5780 t91C mLog.cpp:324 - 'TM' Starting Phase 1 for reason = 'p_XXX.XXX.XXX.XXX_1_18f5718 IPSec Policy GroupSmiley Tongue_XXX.XXX.XXX.XXX_1_18f5718 IKE SA Rule'
00204,09 2019/05/15 12:17:15.920 3 SYSTEM PulseSecureService.exe dsTMService p5780 t91C mLog.cpp:324 - 'TM' SAAction performed - name = 'p_XXX.XXX.XXX.XXX_1_18f5718 IKE Negotiation Action' type = 'Negotiated IKEv5'
00140,09 2019/05/15 12:17:15.922 3 SYSTEM PulseSecureService.exe dsTMService p5780 t91C mLog.cpp:324 - 'TM' Calculated Refresh Lifetime = 25866 sec
00135,09 2019/05/15 12:17:15.922 3 SYSTEM PulseSecureService.exe dsTMService p5780 t91C mLog.cpp:324 - 'TM' Calculated Refresh Lifetime = 0 KB
00203,09 2019/05/15 12:17:15.922 3 SYSTEM PulseSecureService.exe dsTMService p5780 t91C mLog.cpp:324 - 'TM' Marshal P1 Encryption = 7, Keylength = 128, Hash = 2, Group = 2, Lifetime = 28740 sec, Lifetime = 0 KB
00130,09 2019/05/15 12:17:15.923 3 SYSTEM PulseSecureService.exe dsTMService p5780 t91C mLog.cpp:324 - 'TM' MyID = FQDN:'dynvpn':0:17
00142,09 2019/05/15 12:17:15.923 3 SYSTEM PulseSecureService.exe dsTMService p5780 t91C mLog.cpp:324 - 'TM' --> SendInitialPacket Phase 1 packet ID=1
00168,09 2019/05/15 12:17:15.923 3 SYSTEM PulseSecureService.exe dsTMService p5780 t91C mLog.cpp:324 - 'TM' New Phase 1 Session (I) Created UID=00000001 with Peer UID=00000001
00128,09 2019/05/15 12:17:16.256 3 SYSTEM PulseSecureService.exe dsTMService p5780 t109C mLog.cpp:324 - 'TM' Setup New Responder Cookie
00158,09 2019/05/15 12:17:16.256 3 SYSTEM PulseSecureService.exe dsTMService p5780 t109C mLog.cpp:324 - 'TM' ProcessFirstAggressivePacketAsInitiator_Preshared() ID=1
00206,09 2019/05/15 12:17:16.256 3 SYSTEM PulseSecureService.exe dsTMService p5780 t109C mLog.cpp:324 - 'TM' Unmarshal P1 Encryption = 7, Keylength = 128, Hash = 2, Group = 2, Lifetime = 28740 sec, Lifetime = 0 KB
00141,09 2019/05/15 12:17:16.256 3 SYSTEM PulseSecureService.exe dsTMService p5780 t109C mLog.cpp:324 - 'TM' Calculated Refresh Lifetime = 25866 sec
00136,09 2019/05/15 12:17:16.256 3 SYSTEM PulseSecureService.exe dsTMService p5780 t109C mLog.cpp:324 - 'TM' Calculated Refresh Lifetime = 0 KB
00130,09 2019/05/15 12:17:16.256 3 SYSTEM PulseSecureService.exe dsTMService p5780 t109C mLog.cpp:324 - 'TM' PeerID = IP:XXX.XXX.XXX.XXX:0:0
00116,09 2019/05/15 12:17:16.257 2 SYSTEM PulseSecureService.exe dsTMService p5780 t109C mLog.cpp:321 - 'TM' Invalid HASH_R
00158,09 2019/05/15 12:17:26.493 3 SYSTEM PulseSecureService.exe dsTMService p5780 t109C mLog.cpp:324 - 'TM' ProcessFirstAggressivePacketAsInitiator_Preshared() ID=1
00206,09 2019/05/15 12:17:26.493 3 SYSTEM PulseSecureService.exe dsTMService p5780 t109C mLog.cpp:324 - 'TM' Unmarshal P1 Encryption = 7, Keylength = 128, Hash = 2, Group = 2, Lifetime = 28740 sec, Lifetime = 0 KB
00141,09 2019/05/15 12:17:26.493 3 SYSTEM PulseSecureService.exe dsTMService p5780 t109C mLog.cpp:324 - 'TM' Calculated Refresh Lifetime = 25866 sec
00136,09 2019/05/15 12:17:26.493 3 SYSTEM PulseSecureService.exe dsTMService p5780 t109C mLog.cpp:324 - 'TM' Calculated Refresh Lifetime = 0 KB
00130,09 2019/05/15 12:17:26.493 3 SYSTEM PulseSecureService.exe dsTMService p5780 t109C mLog.cpp:324 - 'TM' PeerID = IP:XXX.XXX.XXX.XXX:0:0
00116,09 2019/05/15 12:17:26.497 2 SYSTEM PulseSecureService.exe dsTMService p5780 t109C mLog.cpp:321 - 'TM' Invalid HASH_R

 

Running Pulse Secure 9.0.2 (1421)

 

The funny thing is this: I can log out of my domain account, log into a local user account, and the connection works just fine.

Has anyone seen this before?

2 REPLIES 2
Occasional Contributor

Re: Invalid HASH_R

Ok I figured this out, but I didn't figure out why it was happening.

 

I joined this computer to the domain over the VPN.
I went to the local network, unjoined then rejoined, and it works.

Not sure how to reconcile that, but take it for what it is.

Moderator

Re: Invalid HASH_R

thank you for letting us know