cancel
Showing results for 
Search instead for 
Did you mean: 

PSAL - It appears that the application launcher is not installed

m.ferrara
Contributor

PSAL - It appears that the application launcher is not installed

I have two appliance PSA5000 in cluster (Version: 9.1R9 build 9189).

 

I configured all correclty few months ago, and all works fine.

 

Few weeks ago, I was trying to enable Host Checker, but I have this problem:
On some pc client, if I use Chrome (or Firefox) to login on the SSLVPN portal, I'm waiting 60 seconds and the system can't start connection on Pulse Connection Desktop with this message in the browser: "It appears that the application launcher is not installed", if I click on "try again" after 10 second the system can start correcly Pulse Connection Desktop, and all works fine. 

 

But for example, from my pc all works correctly using Chrome.

 

I read that the problem is on the PSAL when I using a different browser from IE, but I don't understand why on some doesn't work and works on others.
How can resolve this problem on all pc?

 

Thanks for the support.
Marco

3 REPLIES 3
r@yElr3y
Moderator

Re: PSAL - It appears that the application launcher is not installed

@m.ferrara Is the VPN client gets auto-launched after logging into the web portal? I remember seeing a similar behavior when we have host-checker enabled followed by pulse client auto-launch.

 

HC will  be successfully launched by PSAL, however pulse client launch will time-out during the PSAL search... which is happening due to the JS security mechanism designed in Chrome.


Is it working when you manually start the Pulse Client?

PCS Expert
Pulse Connect Secure Certified Expert
m.ferrara
Contributor

Re: PSAL - It appears that the application launcher is not installed

Hi [email protected] ,

thank you for your reply.

 

Why did it is only on some chrome and not on all?

I have the same Chrom version, on two different PC, on one works and on another no.

 

Can I set  JS security on chrome, to allow it?

 

r@yElr3y
Moderator

Re: PSAL - It appears that the application launcher is not installed

@m.ferrara Can you please capture the network and console logs from Chrome during the PSAL search and see if any errors were reported. Compare them betwoen working and non-working scenarios.

 

To my knowledge, JS security is a built-in functionality, not aware of any workarounds apart from retrying the PSAL search or disabling the Pulse auto-launch.

PCS Expert
Pulse Connect Secure Certified Expert